Gestion des adhérents

Gestion des adhérents v. 6.47

 Accueil Suivant

Présentation

L'application MJC permet de gérer les adhésions, les activités (dont centres de loisirs et journées récréatives), et les règlements associés.

Cette application, indépendante de tout autre logiciel, utilise cependant une base de données au format Microsoft ACCESS 2, de sorte que l'exploitation des données saisies peut, si nécessaire, se faire par d'autres applications

Elle est utilisable en réseau (avec déploiement automatique des nouvelles versions en réseau local, et/ou mise à jour automatique par internet), et permet l'export des données vers une comptabilité de type SYBEL, CIEL , EBP, SAGE ou QUADRATUS.

L'application se compose de six modules principaux:

·la saisie d'un adhérent

·la consultation du fichier adhérents

·les impressions

·les statistiques

·les opérations générales (dont le catalogue internet)

·les tables (communes, activités, professions) et paramètres divers

L'application permet la gestion simultanée de plusieurs centres de loisirs, et de plusieurs journées récréatives.

L'accès aux différents modules peut se faire aussi bien par les différents boutons que par le menu rapide d'accès.

La version initiale de l'application a été développée en 1994. Depuis cette date, l'application a subi de nombreuses évolutions, pour compléter ses fonctionnalités (centres de loisirs, journées récréatives, tarifs multiples...), s'adapter aux méthodes de travail et aux besoins d'utilisateurs toujours plus nombreux, et garantir son évolution (problème an 2000, passage à l'euro...).

La version initiale en 16 bits assurait la compatibilité avec toutes les plates formes windows jusqu'à Windows Vista : depuis les versions Windows Seven 64 Home, la compatibilité 16 bits n'étant plus assurée, il convient d'utiliser une version au minimum 5.0.0 de l'application. Néanmoins, sur les plate-formes existantes, toute version nouvelle peut remplacer les versions anciennes, l'application assurant, si nécessaire, la conversion automatique des données.

Ce programme n'est pas libre de droit. Son utilisation nécessite son acquisition en règle auprès de la société ADAGIO.

Touches d'accès rapide

F1 | Aide de l'application
F2 | Saisie d'un adhérent
F3 | Consultation d'un adhérent
F4 | Recherche d'adhérents
F5 | Tables communes
F6 | Table des activités
F7 | Table des professions
F8 | Expéditeur de SMS
F9 | Expéditeur d'emails
F11 | Calendrier
F12 | Calculatrice

Menus contextuels sur les tableaux
Sur la majorité des données présentées sous forme de tableaux, le bouton droit de la souris donne accès au menu contextuel permettant généralement de copier le tableau vers le presses papiers, d'en transférer le contenu vers Excel (si installé), d'imprimer la tableau ou de l'agrandir en plein écran.

ADAGIO

1, rue de la Gare

54450 BLAMONT

Tél : 03.83.42.39.73

http://www.adagio.com.fr/mjc

RCS Nancy B 398.487.793

SYBEL est une marque déposée de SAGE France SA (anciennement SYBEL Sa)

Ciel est une marque déposée de CIEL SA - 11, rue de Cambrai - 75019 Paris

EBP est une marque déposée de EBP Informatique SA - ZA du Bel Air - BP 95 - 78513 Rambouillet cedex

SAGE est une marque déposée de SAGE France SA - 10, rue Fructidor - 75017 Paris

QUADRATUS est une marque déposée de QUADRATUS SA - parc du club du Golf - 350, av. Gauthier de la Lauzière - 13856 Aix en Provence cedex 3


Guide de démarrage

 Accueil Précédent Suivant

Ce chapitre s’adresse aux utilisateurs soucieux de paramétrer rapidement l’application pour une première utilisation.

1. - Paramètres généraux

Dans le menu paramètres, 'Généralités', saisissez les coordonnées de l’établissement (bouton "Coordonnées"), en 'Table et données' et saisissez (bouton "Numéros") le prochain numéro d’adhérent (proposé par défaut à 1).

2. - Modes de règlement

La table des modes de règlement n’est pas renseignée. Vous devez au préalable la remplir, ou importer une table existante, telle celle fournie avec l’application.

Pour importer la table existante :

- dans les paramètres, sélectionner Importation

- indiquer en unité source votre disque dur courant (généralement, C :)

- cliquez sur importation des modes de règlement

3. - Professions

La table des professions n’est pas renseignée. Vous devez au préalable la remplir, ou importer une table existante, telle celle fournie avec l’application.

Pour importer la table existante :

- dans les paramètres, sélectionner Importation

- indiquer en unité source votre disque dur courant (généralement, C :)

- cliquez sur importation des professions

4. - Communes

La table des communes n’est pas renseignée. Vous pouvez opter pour :

- la remplir manuellement des communes les plus importantes

- la remplir au cours des saisies des adhérents

- la remplir automatiquement à l’aide du gestionnaire de codes postaux

5. - Table des activités

Définir correctement la table des activités est la tache la plus ardue. Il convient en effet de créer les activités existantes en prévoyant un maximum de souplesse pour l’usage ultérieur.

- Choisissez un code explicite (ex : GYM01 pour le premier cours de Gymnastique, GYM02, etc...). Ce code devra non seulement permettre de saisir rapidement l’activité choisie, mais permettra aussi des éditions et statistiques regroupant des activités dont les codes sont successifs (tous les codes GYM par exemple)

- Séparez les différentes séances en autant d’activités différentes, de sorte qu’à un code unique corresponde une activité, un groupe et un horaire unique. Certes, cette méthode implique une multiplication des codes activités, mais permettra une gestion affinée; ces codes seront par ailleurs repris automatiquement l’année suivante, de sorte que le démarrage de la prochaine année en sera facilité.

- Créez des codes pour les différentes adhésions (ex : ADH01, ADH02...) et pensez si nécessaire à les affecter immédiatement aux tranches d’âges concernées

6. - Centres de loisirs et journées récréatives

Si vous souhaitez utiliser la souplesse de gestion des centres de loisirs et journées récréatives, indiquez immédiatement les tarifs des centres de loisirs et journées récréatives en Paramètres - Centres de Loisirs - Tarifs (Paramètres - Journées récréatives - Tarifs).
(Si vous gérez plusieurs lieux de centre de loisirs ou de journées récréatives simultanés, il conviendra aussi de gérer la table des codes automatiques).

7. - Zones libres

Les fiches adhérents peuvent contenir jusqu'à 6 zones libres, que vous pouvez définir librement (n° caf, téléphone, etc). Si vous souhaitez utiliser de telles zones, définissez les en Paramètres - Zones libres, en indiquant les zones contenant éventuellement une adresse email ou un numéro de SMS.

De nombreux autres paramètres (Tranches d’âges pour statistiques, Certificats, etc...) pourront être adaptés ultérieurement.


Saisie d'un adhérent

Généralités sur le numéro d'adhérent :

- ce numéro est unique

- il est séquentiel, géré dans l'ordre des demandes d'adhésions

- à chaque rupture d'année, le compteur est remis à un nombre entier de milliers

Le numéro d'adhérent est affecté automatiquement.

La fiche adhérent se compose:

·du code adhérent, automatique

·du nom (sur 20 caractères), automatiquement converti en majuscules

·du prénom (sur 20 caractères), dont la première lettre est convertie en majuscule.

S'il existe une base pour l'année antérieure, la commande HISTORIQUE permet de récupérer les éléments de l'adhérent dans la base de l'année précédente (sauf activités et règlements). Ce bouton permet non seulement d'éviter de ressaisir des informations, mais permet aussi l'édition de statistiques sur les reprises par historiques (voir Statistiques).
Il permet deux modes de fonctionnement :
- si ni nom ni prénom ne sont saisis, le rappel se fait selon l'ancien code adhérent
- si nom et prénom sont saisis, le rappel se fait sur le nom (et/ou prénom).

Si l'option 'Reprise d'Historique' est activée en Paramètres, la reprise de l'historique est automatiquement proposée dès la validation du prénom.

La commande FAMILLE permet d'obtenir la liste des fiches existantes sous le même nom, avec possibilité de reprise des éléments (sauf activités, règlements, prénom, date de naissance, sexe, et responsable s'il est non vide). Ce bouton est aussi utilisable après la saisie du nom du responsable légal: la recherche est alors effectuée tout d'abord sur le nom de l'adhérent, puis sur le nom du responsable.

Après la saisie du nom et du prénom, la fiche n'est accessible qu'après validation par la touche "Entrée" (ou l'usage éventuel des boutons HISTORIQUE ou FAMILLE)

La fiche se compose aussi:

·du genre : M., Mlle, Mme, ou Sans (personnes morales,...) proposé par défaut (voir paramètres)

·de l'adresse, composée de:

- deux lignes de rue

- code postal: la saisie du code postal implique la frappe automatique de la commune si le code postal est déjà connu, ou l'affichage de la liste des communes dont le début de code postal correspond au code saisi, avec sélection par double-clic. L'appui sur la touche ESC dans la fenêtre de sélection des communes permet la création d'une nouvelle commune dans la table, à condition que le code postal saisi ait 5 chiffres. Si le code postal est inconnu, il faut utiliser le code 00000.

- commune: la saisie de la commune implique la frappe automatique du code postal si la commune existe, ou l'affichage de la liste des communes dont le début du nom correspond aux lettres saisies, avec sélection par double-clic. L'appui sur la touche ESC dans la fenêtre de sélection des communes permet la création d'une nouvelle commune dans la table.

·de deux numéros de téléphone

·du nom du responsable légal (cette zone peut avoir un contenu quelconque, mais il est préférable de faire précéder un éventuel prénom du nom, afin de permettre l'utilisation du bouton FAMILLE). De même, le bouton () associé permet si nécessaire de compléter le nom du responsable légal par son propre numéro d'adhérent, recherché automatiquement dans la base, et inscrit dans la zone responsable entre parenthèses.

·de la date de naissance (non obligatoire). La saisie de la date de naissance implique la proposition automatique de l'adhésion correspondante si la table 'Tranches d'âges-adhésion' est remplie (voir paramètres)

·du reste dû: cette valeur est généralement à 0 puisqu'elle est automatiquement mise à jour par la saisie des règlements. Si la double monnaie (voir paramètres) est activée, la monnaie est indiquée sous la forme d'un bouton qui vous permet de basculer vers l'affichage dans la seconde monnaie.
Note : Si suite à des manipulations de règlements ou d'activités, il s'avérait q'une erreur se soit glissée dans le calcul du reste dû, un double-clic sur le symbole monétaire permet le recalcul.

·du code profession: la saisie de ce code entraîne l'affichage automatique du libellé, ou la sélection d'un code dans la table des professions par double-clic sur l'élément choisi. Si la profession est inconnue, il faut utiliser le code 000.

·de neuf zones optionnelles (voir zones libres en paramètres)

·des activités: les différentes activités sélectionnées sont saisies par leurs codes. Un même code ne peut apparaître qu'une fois pour un même adhérent. Le règlement associé peut être automatiquement affecté lors de la saisie de l'activité. L'activité peut être déclarée de type hebdomadaire (valeur 1 dans colonne F) ou uniquement tous les quinze jours (vide en colonne F). Cette fréquence d'activité modifie les statistiques de présence. La saisie d'un code activité inexistant entraîne l'affichage de la liste des activités, avec sélection par double-clic. La date de saisie permet de retrouver aisément les inscriptions récapitulées par les Statistiques de répartition sur une période.

Si l'activité est un centre de loisirs, et que son code n'est pas connu, le bouton 'Centre de loisirs' permet de sélectionner les dates sur le calendrier: si un code centre de loisirs existe pour les critères choisis, il est automatiquement affecté; dans le cas contraire, sa création automatique est proposée.

Si l'activité est une journée récréative, et que son code n'est pas connu, le bouton 'Journée récréative' permet de sélectionner les dates sur le calendrier: si un code journée récréative existe pour les critères choisis, il est automatiquement affecté; dans le cas contraire, sa création automatique est proposée.

Si la gestion de tarif spécifique aux adhérents a été activée (voir paramètres - Libellé des tarifs, avec indication sur la fiche adhérent d'un tarif spécifique à l'adhérent) ou si un tarif spécial est affecté à la commune, le tarif correspondant est automatiquement sélectionné.

Note sur les montants: le montant de chaque activité est par défaut égal à celui de la table des activités, choisi si nécessaire parmi les dix tarifs proposés en fonction du code postal de la commune, du tarif spécifique de l'adhérent. Il est cependant possible de modifier ce montant dans la fiche adhérent (impliquant bien entendu, proposition de règlement automatique de ce nouveau montant, génération des écritures comptables sur ce montant, et recalcul du montant restant du). L'utilisateur pourra au choix décider s'il modifie ici le montant de l'activité (cas par exemple dune réduction standard lorsque deux activités sont prises simultanément) , ou sil ne modifie pas le montant mais crée un règlement de type 'participation' ou 'réduction' (cas par exemple d'une remise spécifique à un adhérent, qui sera alors comptabilisée en compte de charges mais permettra par analyse de ce mode de règlement de déterminer l'ampleur de ce type de remise).

· des règlements: un nombre quelconque de règlement peut être saisi. La date affectée est la date du jour. Le type standard de règlement est défini dans la table des modes de règlements (voir paramètres).
Toute opération sur les règlements affecte le montant restant dû. Une échéance peut-être indiquée pour chaque régalement (voir paramètres pour la table des échéances)

Les commandes disponibles sont:

·IGNORER: Retourne à la saisie d'un nom et prénom. Si la fiche courante n'a pas été validée, il est toujours possible d'annuler cette commande pour valider au préalable.

·VALIDER: Valide les modifications et retourne à la saisie du nom.

·LISTE des ACTIVITES: la liste complète et détaillée des activités est toujours disponible.

·AUTRES IMPRESSIONS:

- Fiche : imprime la fiche adhérent détaillée

- Facture :pour imprimer entre deux dates données les activités choisies et les règlements effectués par un adhérent. Cette option n'est disponible que si la fonction d'édition de factures a été activée en "Paramètres - Facture" . Le numéro de facture est automatiquement incrémenté après l'impression.

Le terme de 'Facture' peut être adapté en "Paramètres - Facture" (ex: Reçu).
L'année (saison) apparaît à gauche selon la valeur saisie en Paramètres - Divers - Texte année (saison)

- Certificats: pour une activité, pour un stage, pour un centre de loisirs ou pour une journées récréatives. Ces différentes impressions sont proposées selon les 'activités' choisies par l'adhérent. (Voir Editeur de certificats)

- Etiquette adresse sur imprimante ligne: cette commande utilise l'imprimante ligne (imprimante utilisée pour l'impression des cartes) pour éditer rapidement une étiquette à l'adresse de l'adhérent sur les étiquettes destinées aux cartes, selon le format d'étiquettes défini pour ces cartes.

- Courrier libre : édite le texte libre saisi par l'éditeur de certificat, en incluant si nécessaire les références à un code activité.

· IMPRIMER CARTE: permet l'impression de l'étiquette (voir paramètres) sur une imprimante dédiée. (Note: cette impression peut être différée puisqu'elle est aussi disponible en mode consultation des adhérents, et qu'il est même possible d'automatiser l'impression d'une série de cartes dans le menu Impressions)

Catalogue internet : si les fonctionnalités de génération de catalogue internet sont activées avec gestion des fiches adhérents, le bouton "Catalogue internet" (raccourci Ctrl+F12) présente l'accès à l'URL de l'adhérent, ainsi que le QRcode correspondant. Si une adresse email est disponible pour l'adhérent, la fenêtre propose de l'informer par mail du lien, accompagné ou non de l'image du QRcode.


Consultation des adhérents

La sélection d'un adhérent peut se faire par:

- saisie du code

- saisie du nom, avec affichage automatique ou sélection dans la liste des adhérents dont les

éléments saisis correspondent.

- usage des boutons 'magnétoscope':

début de fichier dans l'ordre alphabétique

nom précédent

nom suivant

fin de fichier

L'ensemble des opérations permises sur la fiche est le même que pour le module de saisie, hormis qu'après modification d'une fiche, il est possible

- soit de 'Valider' la fiche, qui enregistre les modifications mais conserve son affichage permettant ainsi par exemple de continuer à utiliser les boutons magnétoscopes pour accéder à la fiche alphabétique suivante

- soit de 'Valider et ignorer', qui enregistre la fiche mais réaffiche le masque de saisie à vide.

Les commandes supplémentaires sont:

·SUPPRIMER: supprime définitivement la fiche adhérent et tous les éléments associés (activités, règlements...)

·RECHERCHE: ce module permet d'effectuer une recherche multi-critères sur l'ensemble de la base de données. Tant que la recherche n'est pas lancée (ou relancée), la liste des adhérents correspondants permet d'accéder par double-clic à la fiche complète (attention: si des éléments de la fiche sont modifiés de sorte que les critères de recherche ne lui correspondent plus, seule la relance de recherche mettra la sélection à jour).

Remarques:
- le critère activité peut être donné en code complet (avec sélection dans la table des activités si nécessaires, ou partiel avec correspondance des premiers caractères).

- la saisie des dates 'Entre... et ...' n'implique pas de saisir la seconde date dans le cas d'une recherche sur un jour précis.
- après une recherche, il est possible de naviguer dans la sélection directement à partir de la fenêtre 'consultation' à l'aide des boutons de navigation situés à droite du bouton 'Recherche'

La liste des adhérents ainsi trouvés peut être imprimée de diverses manières:

- sous forme de liste simple (impression rapide des données de la liste)

- sous forme d'une liste avec les numéros d'adhérents (par ordre alphabétique de noms, ou par numéros d'adhérents croissants)

- sous forme d'une liste avec les adresses (par ordre alphabétique de noms, ou par numéros d'adhérents croissants)

- sous forme d'étiquettes adresse (même format d'impression que pour les étiquettes par activités)

- sous forme d'étiquette adresse sur imprimante ligne: cette commande utilise l'imprimante ligne (imprimante utilisée pour l'impression des cartes) pour éditer rapidement les étiquettes adresse des adhérents sur les étiquettes destinées aux cartes, selon le format d'étiquettes défini pour ces cartes. Une seule étiquette est imprimée par adhérent, mais si plusieurs étiquettes de front ont été définies pour l'impression des cartes, l'ensemble de ces étiquettes est utilisé.

Les fiches adhérents trouvées peuvent être exploitées par différents modules, accessible dans la liste déroulante en bas de sélection :

- par défaut, si les fonctions email ou SMS sont déclarées sur des zones libres, des modules de sélection permettent d'alimenter directement les différents modules expéditeurs (mail ou sms). De même un module "exporter" permet d'enregistrer dans un fichier texte, ou d'envoyer à Excel (si installé) ou Word (si installé), les données relatives aux adhérents sélectionnés (avec choix du séparateur pour les formats texte et word) L'utilisateur peut sélectionner les zones à exporter pour chaque fiche (case cochée), ainsi que l'ordre d'export (en déplaçant les lignes) : ces paramètres d'exportation sont conservés après arrêt de l'application.

- le module "exporter" permet de transférer le contenu des fiches adhérents, détaillées et ordonnées selon le choix de l'utilisateur, vers Word, Excel ou un fichier texte avec choix du séparateur.
L'utilisateur peut ajouter dans cette liste des développements de son choix en utilisant les normes de plug in.

Catalogue internet : si les fonctionnalités de génération de catalogue internet sont activées avec gestion des fiches adhérents, le bouton "Catalogue internet" (raccourci Ctrl+F12) présente l'accès à l'URL de l'adhérent, ainsi que le QRcode correspondant. Si une adresse email est disponible pour l'adhérent, la fenêtre propose de l'informer par mail du lien, accompagné ou non de l'image du QRcode.


Impressions

Les éditions peuvent être lancées:

·sur imprimante: avec possibilité de sélection de l'imprimante et du nombre de copies

·sur fichier (pour export vers d'autres logiciels), dans différents formats

·sur écran: avec possibilité de voir chaque page séparément, en mode page ou zoom, et d'imprimer si nécessaire sur l'imprimante sélectionnée par défaut.

·en pdf directement envoyé par email (voir Pdf)

ATTENTION: certaines éditions peuvent nécessiter un temps important de traitement.

Les impressions sont:

Pour les adhérents :

·ANNUAIRE: tous les adhérents avec nom, prénom et numéros de téléphone, par ordre alphabétique

·TABLEAU d'APPEL pour une ACTIVITE: document permettant d'indiquer la présence des différents adhérents d'une activité donnée.

·LISTE pour une ACTIVITE: après sélection de l'activité, édite l'annuaire des adhérents concernés, en indiquant la fréquence de l'activité, si l'adhérent est à jour ou non (vide ou non dans colonne à jour) et le total des adhérents concernés.

·LISTE pour une ACTIVITE: AVEC MAILaprès sélection de l'activité, édite l'annuaire des adhérents concernés, en indiquant la fréquence de l'activité, si l'adhérent est à jour ou non (vide ou non dans colonne à jour), la première adresse mail trouvée dans les zones libres, et le total des adhérents concernés.

·LISTE par ACTIVITE de ... à ...: édite l'annuaire des adhérents concernés pour chaque activité dont le code est compris entre les codes saisis, en indiquant la fréquence de l'activité, si l'adhérent est à jour ou non (vide ou non dans colonne à jour) et le total des adhérents concernés.

·LISTE par ACTIVITE de ... à ...: AVEC MAIL édite l'annuaire des adhérents concernés pour chaque activité dont le code est compris entre les codes saisis, en indiquant la fréquence de l'activité, si l'adhérent est à jour ou non (vide ou non dans colonne à jour), , la première adresse mail trouvée dans les zones libres, et le total des adhérents concernés.

·LISTES par ACTIVITES pour un JOUR donné: effectue la même liste que précédemment pour chaque activité se déroulant le jour de la semaine indiqué.

·REGISTRE D'ASSEMBLEE GENERALE : établit une liste numérotée des adhérents avec la date de naissance, la date d'adhésion et une case d'émargement.
Note : sont considérés comme adhérents les inscrits dont une activité est relative à un code figurant dans les tranches d'âges pour adhésion automatique.

·ETIQUETTES pour une ACTIVITE: édite pour chaque adhérent concerné une étiquette adresse. (pour des étiquettes sur d'autres critères, utilisez la fonction Imprimer du module de Recherche en Consultation).

· ETIQUETTES TRIEES PAR ACTIVITES: édite pour une série de codes activités donnée (code d'adhésions non compris) et pour chaque adhérent une étiquette adresse, indiquant l'une de ses activités.Cette édition permet par exemple l'édition des étiquettes pour des convocations à une assemblée générale et remise en main propre par les animateurs, sans pour autant qu'un adhérent ayant plusieurs activités soit convoqué plusieurs fois. (pour des étiquettes sur d'autres critères, utilisez la fonction Imprimer du module de Recherche en Consultation).

·ETIQUETTES POUR ADHERENTS SANS ACTIVITES: cette édition complète la précédente en éditant les étiquettes pour les adhérents n'ayant aucune activité (pour des étiquettes sur d'autres critères, utilisez la fonction Imprimer du module de Recherche en Consultation).

·LISTE des SANS ACTIVITE: annuaire ne concernant que les adhérents non inscrits à une activité.

·LISTE des NON ADHERENTS: cet état qui liste les inscrits ayant au moins une activité sans être adhérents, permet principalement de détecter les oublis de saisie. Si la MJC "offre" certaines adhésion, il sera préférable par souci de cohérence de créer un mode de règlement du type "participation MJC" (affecté à un compte de charge comptable), et de saisir des adhésions affectées à ce mode. On pourra ainsi non seulement détecter aisément les véritables erreurs, mais aussi contrôler l'ampleur des services "gratuits" tout en respectant l'obligation d'adhésion (en matière d'assurance par exemple).

·LISTE détaillé pour ACTIVITES de ... à ... avec ADHERENTS TRIES PAR AGES: cette liste permet la répartition des inscrits en groupe selon l'âge.

·LISTE détaillé pour ACTIVITES de ... à ... avec ADHERENTS TRIES PAR COMMUNES: cette liste permet par exemple d'organiser le ramassage des inscrits.

Pour les activités:

·LISTE des ACTIVITES: indique le code, le libellé, le nombre maximum d'inscriptions, le nombre d'inscrits et le nombre de places disponibles.

·LISTE DETAILLEE des ACTIVITES

Selon les activités, pour chaque adhérents:

·CERTIFICATS pour une activité : après indication d'un code d'activité, édition d'un certificat d'activité (voir éditeur de certificat) pour chaque adhérent concerné.

·CERTIFICATS pour un stage: après indication d'un code de stage, édition d'un certificat de stage (voir éditeur de certificat) pour chaque adhérent concerné.

·CERTIFICATS pour des centres de loisirs, du code ... au code ...: après indication des codes, édition d'un certificat de centres de loisirs (voir éditeur de certificat) pour chaque adhérent concerné par chacun des codes centres de loisirs compris dans la tranche de codes indiquée.

Note: aucune impression n'est déclenchée lorsqu'aucun centre de loisirs n'est compris dans la tranche de code indiquée.

·CERTIFICATS pour des journées récréatives, du code ... au code ...: après indication des codes, édition d'un certificat de journées récréatives (voir éditeur de certificat) pour chaque adhérent concerné par chacun des codes journées récréatives compris dans la tranche de codes indiquée.

Note: aucune impression n'est déclenchée lorsqu'aucune journée récréative n'est comprise dans la tranche de code indiquée.

·COURRIER LIBRE : pour une activitée donnée, édite le courrier libre saisi à l'aide de l'éditeur de certificats

Pour les centres de loisirs :

·CENTRES de LOISIRS : LISTE détaillée sur une PERIODE donnée: dresse la liste nominative (avec n° de téléphone, nombre de matins, de repas et d'après-midi) des adhérents inscrits en centres de loisirs, après sélection ou non d'un lieu précis (permettant ainsi de gérer plusieurs Centres de Loisirs autonomes)

·CENTRES de LOISIRS : LISTE sur PERIODE, LIEU et REGLEMENT : cet état permet de principalement d'établir la liste des allocataires CAF pour un centre de loisir. Pour pouvoir établir cet état, il convient au préalable :

- d'affecter une zone libre pour le numéro d'allocataire

- de créer un mode de règlement spécifique (bon CAF, ticket allocataire...)

Pour les journées récréatives :

·JOURNEES RECREATIVES : LISTE détaillée sur une PERIODE donnée: dresse la liste nominative (avec n° de téléphone, nombre de matins, de repas et d'après-midi) des adhérents inscrits aux journées récréatives.

Pour les règlements :

·LISTE des VERSEMENTS entre 2 DATES pour un TYPE de paiement (modes de règlements - voir paramètres): après indication des bornes de dates concernées et sélection du type de paiement, établit la liste des règlements correspondants avec la date, le code de l'adhérent, le libellé de l'opération et le montant.

·LISTE des VERSEMENTS entre 2 DATES: pour chaque type de paiement, établit la même liste que précédemment.

·LISTE des VERSEMENTS pour UNE ACTIVITÉ entre 2 DATES:

- Selon Compta: édite la liste des versements enregistrés selon le code comptable sur la période donnée. Cette liste ne peut donner de résultat concret que si le code comptable de l'activité a été indiqué sur la fiche règlement, soit manuellement lors de la saisie, soit automatiquement (en cas de réponse Oui à la question Voulez-vous enregistrer le règlement? lors dune saisie d'activité)

- Reconstitués: cet état regroupe les versements de l'état Selon compta et y adjoint si possible les règlements effectués sur la période pouvant être considéré comme relatif à une activité sans pour autant que le code comptable soit indiqué. Cette méthode n'est cependant pas infaillible: par exemple, si deux activités sont choisies sur la même période et que le règlement enregistré ne correspond pas au total, l'écart sera visible à la fois sur les états de chaque activité (d'où erreur en cas de totalisation ultérieure).

·COMPTES NON SOLDES : établit la liste détaillée (code, nom, adresse...) des adhérents dont le montant restant dû est non nul, ou <0 (cas des avoir), ou >0 (reste dû).

·REGLEMENTS à ECHEANCE entre deus dates : établit la liste des règlements à échéances afin par exemple de savoir quelles pièces remettre à l'encaissement.

·REGLEMENTS entre deux dates par ADHERENTS d'une ACTIVITE : cet état complète la LISTE des VERSEMENTS pour une ACTIVITE. En effet, vu l'impossibilité pratique d'affecter un règlement global pour solder la somme due sur un ensemble d'activités (notamment lorsque les règlements sont partiels), il est parfois ardu de retrouver dans les paiements ceux qui auraient été fait fait pour une activité spécifique. Cet état, après indication d'une tranche de codes d'activités, établit la liste de tous les règlements compris entre deux dates pour les adhérents concernés par ces activités.

·CARTES ADHERENTS : cette commande permet d'imprimer directement une série de cartes d'adhérents SUR L'IMPRIMANTE LIGNE, en indiquant un numéro de départ et d'arrivée. Cette impression se fait selon le format défini pour les étiquettes. (Pour connaître le nombre de fiches concernées entre deux numéros, après avoir saisi le numéro de carte de départ, puis le numéro de carte d'arrivée, recliquez sur la case carte de départ avant de valider !)

Et aussi :

·ETATS COMPLEMENTAIRES: cette option a pour but de permettre d'ajouter de nouveaux états au fil du temps, sans modifier le programme. Au départ, aucun état imprimé complémentaire n'est disponible, puisque toutes les impressions nécessaires sont prévues.


Statistiques

·REPARTITION par AGES et par SEXES : calcule la répartition complète selon la table définie en 'Tranches d'âges - Statistiques' (voir paramètres) pour les adhérents seulement, entre deux dates d'adhésions. Cette statistiques peut être complétée par l'analyse des communes et professions sur les mêmes données.

·REPARTITION par ANNEES : calcule la répartition en fonction de l'âge selon la table définie en 'Tranches d'âges - Statistiques' , pour les adhérents, et sur demande l'analyse des communes et professions sur les mêmes données, à partir de tous les fichiers de données MJC présents à l'emplacement courant de la base de donnée.
(l'âge est recalculé au jour et mois de la date courante pour l'année de référence, considérée par défaut à l'année de début de saison. Ainsi MJC2011.MDB est pris en compte pour l'année 2011/2012, MJC2005.MDB pour l'année 2005/2006... )

·REPARTITION par PROFESSIONS: édite la liste des professions avec le nombre d'adhérents correspondant et le pourcentage.

·REPARTITION par ACTIVITES: édite la liste des activités avec le nombre maximum d'inscriptions, le nombre d'inscrits et le nombre de places disponibles

·REPARTITION par COMMUNES: pour un nombre n donné de communes, cet état indique le nombre d'adhérents pour les n plus grosses communes (au sens du nombre d'adhérents) et indique le total pour l'ensemble des autres communes.
Le regroupement est effectué soit par codes postaux (total pour un même code), soit par nom de communes (total pour une même commune).

·REPARTITION par AGES et par SEXES des adhérents repris par le bouton "Historique" : calcule la répartition complète selon la table définie en 'Tranches d'âges-Statistiques' (voir paramètres) en ne tenant compte que des adhérents dont la fiche a été remplie par le bouton "Historique" lors de la création (a priori, adhérents déjà présents l'année précédente).

·REPARTITION par COMMUNES et par SEXES des adhérents repris par le bouton "Historique" : calcule la répartition complète des adhérents par communes en ne tenant compte que des adhérents dont la fiche a été remplie par le bouton "Historique" lors de la création (a priori, adhérents déjà présents l'année précédente).

·REPARTITION par JOURS et par HEURES: ce tableau indique la répartition des adhérents sur une semaine en fonction de leurs activités et de la fréquence de ces activités (un adhérent comptant ainsi 1 ou 0.5 selon que l'activité est hebdomadaire ou tous les quinze jours). Deux méthodes de calcul sont possibles:

- méthode 1: à l'heure indiquée, sont pris en compte les adhérents entrants et les adhérents en cours d'activités. Cette méthode est proche de la réalité des mouvements effectifs.

- méthode 2: les adhérents sortant en plus à l'heure indiquée sont comptabilisés. Cette méthode augmente les valeurs de fréquentation, mais donne le nombre de mouvements à l'instant précis.

·REPARTITION des ACTIVITES par AGES : calcule la répartition complète selon la table définie en 'Tranches d'âges - Statistiques' des adhérents en indiquant le nombre total d'activités choisies (hormis l'adhésion) pour chaque tranche et la moyenne du nombre d'activités.

·REPARTITION des ADHESIONS et INSCRIPTIONS sur une PERIODE: après saisie des bornes de la période, établit les totaux par jours des adhésions et des inscriptions enregistrées.

·ADHERENTS sans adhésion ou à adhésion multiples : selon les codes adhésion définis en Paramètres généraux - Tranches d'âges/Adhesion, établit une liste des adhérents dont les activités comporte, soit aucun des codes adhésions, soit plus d'un. Un double clic dans le tableau permet l'accès direct aux fiches adhérents concernées.

·CENTRES de LOISIRS : REPARTITION par JOURS: pour l'ensemble des centres de loisirs, cet état récapitule par jours le nombre d'adhérents inscrits le matin, au repas et l'après-midi.

Note : les données de cet état sont utilisées lorsqu'un nombre maximum d'inscription doit être géré lors de la saisie des activités des adhérents. Cette table, mise à jour automatiquement, peut néanmoins être intégralement recalculée en cas de doute par le bouton 'recalcul'.

·JOURNEES RECREATIVES : REPARTITION par JOURS: pour l'ensemble des journées récréatives, cet état récapitule par jours le nombres d'adhérents inscrits le matin, au repas et l'après-midi.

Note : les données de cet état sont utilisées lorsqu'un nombre maximum d'inscription doit être géré lors de la saisie des activités des adhérents. Cette table, mise à jour automatiquement, peut néanmoins être intégralement recalculée en cas de doute par le bouton 'recalcul'.

·JOURNEES RECREATIVES : INSCRITS pour un JOUR DONNÉ : dresse un état complètement paramétrable des inscrits pour une journée, en dressant le tableau :
- des zones sélectionnées dans l'onglet paramètres (coche en colonne 2 du tableau), dont l'ordre peut être modifié (par déplacement dans le tableau)
- pour les adhérents inscrits dont certaines zones de la fiche sont éventuellement non vides (coche en colonne 4)
- triés éventuellement jusqu'à 5 critères cumulés (définition du n° de critère de 1 à 5 en cliquant dans la colonne 3)

·REGLEMENTS sur une PERIODE : établit la liste et le total des règlements effectués sur une période donnée par mode de règlements (permet par exemple de connaître le fond de caisse). Le tableau peut-être copié dans le presse-papiers par le menu contextuel (bouton droit de la souris)

·RESUME COMPTABLE : si l'interface comptable est activé, ce module calcule les débits et crédits des différents comptes de type 4, 5 et 7.


Table des communes

La table des communes indique (dans l'ordre des codes postaux), le libellé de la commune, le nombre d'adhérents correspondant, et le tarif (1, 2 , 3, ... à 10) proposé automatiquement en saisie ou consultation d'un adhérent de la commune.

Le code postal et le nom de la commune peuvent être modifiés. Si le code postal est modifié, la base des adhérents est remise à jour.

En cas de suppression d'une commune, et si cette commune est celle d'au moins un adhérent, un nouveau code postal de rattachement est demandé pour les adhérents concernés.

Le bouton RECALCUL n'a pas d'utilité si l'application s'est déroulée normalement. Son effet est de recalculer le nombre d'adhérents par commune; ces compteurs sont cependant systématiquement tenus à jour en cours d'application, et ce recalcul ne se justifie qu'en cas de doute, suite à une panne de courant, un arrêt brutal du système, une terminaison anormale de l'application, etc.

Note: pour remplir automatiquement cette table, pensez à utiliser le gestionnaire de codes postaux


Table des activités

La table des activités gère:

·le code de l'activité

·le libellé de l'activité

·le nom de l'animateur

·le lieu de l'activité

·le type d'activité : activité régulière, stage, centre de loisirs ou journée récréative. Pour les centres de loisirs et les journées récréatives, l'information doit être complété par la saisie du détail (Voir Centres de loisirs et Journées récréatives)

·le nombre maximum d'inscriptions : ce nombre, par défaut bloquant (refus des inscriptions en dépassement), peut être dépassé selon le paramètres (voir Paramètres Généraux - Dépassement de limites)

·les tarifs de l'activité: dix tarifs différents peuvent être appliqués, avec proposition automatique selon le code postal lors de la saisie ou de la modification d'une fiche adhérent (voir en saisie d'un adhérent et en table des communes), ou encore application d'un tarif spécifique automatique pour chaque adhérent.

·le libellé apparaissant sur l'étiquette

·5 jours possibles de la semaine avec des tranches horaires (cette table est utile au calcul de la statistique de répartition des adhérents sur la semaine).

·le nombre d'adhérents déjà inscrits

Le code de l'activité comprend 5 caractères : les codes débutant par CL et JR sont de préférence à réserver pour la création des centres de loisir et les journées récréatives, et ce d'autant que l'application peut les créer automatiquement avec ces deux premiers caractères (voir aussi Gestion des centres de loisirs et des journées récréatives)

Par ailleurs, si l'interface comptable est activé, les éléments suivants sont renseignables :

- le code client de l'activité (proposé en standard sous la forme 411 suivi du code de l'activité: de cette manière la consultation de ce compte permet de déterminer comptablement les impayés). Ce code est inutile si le choix dans l'interface comptable concerne le n° d'adhérent et non l'activité (voir paramètres)

- le code de vente (proposé en standard sous la forme 701 suivi du code de l'activité: de cette manière la consultation de ce compte permet de déterminer comptablement le chiffre d'affaire de l'activité)

- le centre analytique comptable. Pour les activités sans code analytique, le code saisi dans les paramètres comptables est utilisé par défaut lors de la génération des écritures..

- le code TVA (en standard, premier code défini dans les paramètres comptables. En standard: Non soumis)

En cas de suppression d'une activité, et si cette activité a été choisie par au moins un adhérent, deux cas se présentent:

·il est possible de détruire la fiche activité et toutes les fiches d'activités adhérents s'y rapportant

·il est possible d'indiquer un nouveau code activité de remplacement (cas par exemple de regroupement de deux activités en une seule).

Pour créer rapidement des codes activités similaires à des codes existants (cas d'activités au trimestre ou au mois, ...) : sélectionnez la fiche activité servant de source. Modifiez le code de l'activité et si nécessaire les renseignements de la ficher, puis validez.

Catalogue internet : si les fonctionnalités de génération de catalogue internet sont activées, le bouton "Catalogue internet" (raccourci Ctrl+F12) présente l'accès au classement dans l'arborescence du catalogue, et permet la saisie d'une description avancée en format HTML (voir les fonctionnalités correspondances en Catalogue internet)


Table des professions

La table des professions indique un code profession, un libellé et le nombre d'adhérents correspondants. En cas de suppression d'une profession, un code de rattachement est demandé pour les adhérents concernés.

Le bouton RECALCUL n'a pas d'utilité si l'application s'est déroulée normalement. Son effet est de recalculer le nombre d'adhérents par professions; ces compteurs sont cependant systématiquement tenus à jour en cours d'application, et ce recalcul ne se justifie qu'en cas de doute, suite à une panne de courant, un arrêt brutal du système, une terminaison anormale de l'application, etc.


Paramètres généraux

Généralités

Coordonnées

Les coordonnées permettent la saisie de l'en-tête des factures, ainsi que des zones nécessaires à l'établissement des certificats.

Mots de passe

Deux mots de passe peuvent être définis:

·mot de passe général, donnant l'accès à l'application

·mot de passe pour l'accès à la gestion des tables. Pour pouvoir modifier ce mot de passe, il sera nécessaire d'indiquer au préalable l'ancien.

Certificats

Voir Editeur de certificats

Utilisateurs

La gestion des utilisateurs permet de personnaliser l'accueil des adhérents en indiquant le nom de la personne ayant procédé à l'enregistrement de la fiche. Une fois la liste des utilisateurs définie et la case 'gestion des utilisateurs' activée, il est nécessaire pour procéder à une saisie ou une consultation de fiches de sélectionner un utilisateur. Le nom de l'utilisateur courant apparaît au menu général, et est reporté sur les factures, précédé de la mention qui a été saisie dans les options de factures (voir ci-dessous "Comptabilité - Facturation").
Il est possible d'automatiser la reprise du dernier nom d'utilisateur lors du démarrage de l'application.

Thèmes visuels

Modifie les couleurs de l'intégralité des fenêtres de l'application en fonction de thèmes visuels proposés, ou de paramètres définis par l'utilisateur.

Dépassement de limites

Un nombre maximum d'inscriptions est défini pour chaque activité. Par défaut, ce nombre ne peut être dépassé, et l'inscription en dépassement ne peut être validée. Cependant, cette option permet de dépasser cette limite, en validant une inscription en dépassement (cas par exemple de membres d'une même famille, s'inscrivant simultanément sans que le dépassement n'entraîne d'impossibilité). De surcroît, le gestionnaire de l'application peut prévoir un mot de passe pour autoriser les dépassements, limitant ainsi cette possibilité à certains utilisateurs seulement.

Aide à la saisie

Genre courant

Le genre courant a pour but de faciliter les saisies, en prédéterminant le genre (le choix de ce paramètre pourra être fait en fonction des statistiques de répartition par sexes).

Tranches d'âges - Adhésions

Ce module détermine 11 tranches d'âges possibles, avec le code correspondant des adhésions. Une bonne définition de cette table permet:

·la proposition automatique d'adhésion lors de la saisie d'un nouvel adhérent, selon sa date de naissance

·la non impression de la ligne Adhésion sur les étiquettes (par défaut, sauf indication contraire)

·les statistiques de répartitions calculées uniquement sur les adhérents.

Note : pour obtenir des statistiques cohérentes, il faut que tous les codes adhésions soit présents dans cette table. Si les codes ne sont pas relatifs à une tranche d'âge (et afin d'éviter la proposition automatique de ces codes en fonction de l'âge), il faut créer des tranches d'ages inutilisées, la saisie permettant de gérer jusqu'à 200 ans.

Par exemple, si un code ADH01 concerne les adhésions de 0 à 15 ans, ADH02 au delà de 15 ans, mais que l'on désire créer un code GRATU pour des adhésions gratuites, il faut pour que les statistiques soient correctes que GRATU figure dans la table, sans interférer.

On peut alors faire la saisie suivante : 0 à 15 : ADH01, 15 à 182 : ADH02, et indiquer GRATUIT dans n'importe laquelle des tranches 3 à 11, puisque ces tranches ne déclencheront logiquement jamais de proposition automatique d'adhésion en fonction de la date de naissance.

Date courante

L'ensemble des traitements d'une session est considéré comme effectué à la date courant, proposée à la date du jour. Ce paramètre, qui n'est pas conservé après fin de l'application, permet de simuler une nouvelle date lors d'une session, sans contraindre ainsi à modifier la date système au panneau de configuration de Windows.
Il est possible aussi de changer le chemin d'accès à la base de données (correspond au changement manuel du fichier CHEMIN.MJC)

An 2000

Dans la majeure partie des applications, la saisie de dates sans l'indication du siècle implique que ces dates sont considérées comme appartenant au vingtième siècle (par exemple 97 donne 1997): cette facilité implique cependant que l'an 00 sera considéré comme 1900 et non 2000, de sorte qu'il sera alors nécessaire de préciser systématiquement une année à 4 chiffres. Cette option facilite la transition en considérant les saisis de 0 à 20 comme de 2000 à 2020.

Historique

Lorsque la base de l'année précédente existe sur le système, le programme propose en saisie d'un adhérent le bouton 'reprise d'historique' qui permet la récupération des données principales de l'adhérents. Si l'option 'Reprise d'historiques automatique' est activée, la recherche dans la base de données de l'année précédente est automatique en saisie dès la validation du prénom.

Note : l'icône outil de ce module permet d'accéder un recalcul général des reprises d'historique sur l'ensemble des bases de données : sont alors considérés comme "repris historiquement" les adhérents de l'année N qui figurent dans une base N-1, avec même nom, même prénom, et même code postal.

Messagerie réseau

Le mode messagerie réseau ouvre une fenêtre permettant de communiquer des messages simples entres les différents utilisateurs connectés sur la même base de données en réseau. L'application surveille l'arrivée de message destiné à l'utilisateur selon la fréquence choisie en 10ème de secondes.
Il peut arriver qu'en mode multi-utilisateur, la validation d'une fiche sur un poste soit bloquée par l'usage de cette même fiche sur un autre, verrouillant l'opération. En cochant "transmettre les informations de blocage réseau", l'utilisateur ayant posé le verrou est automatiquement informé par le message indiqué ici qu'il génère un blocage sur l'autre poste, l'incitant ainsi à clore son opération et à libérer le verrou.

Centres de loisirs

Tarifs

Dix tarifs peuvent être utilisées pour les centres de loisirs. Ils permettent de calculer rapidement le coût d'un centre (même si ces valeurs restent individuellement modifiables lors de la saisie d'un centre), en fonction d'un tarif semaine, jour, matin, après-midi et repas.

Le tarif calculé lors d'un centre est effectué par regroupement (hormis pour les repas) maximum pour minimiser éventuellement le coût. Si l'intégralité de la semaine est sélectionné, le tarif semaine est appliqué à ce bloc au lieu du cumul des tarifs jours; de même pour l'association matin et après-midi qui implique alors le tarif jour. Si aucun tarif dégressif n'est appliqué, il suffit d'indiquer comme tarif jour la somme matin+après-midi et comme tarif semaine la somme du nombre de jours.

Dates prochaines

Pour faciliter la saisie des centres en proposant un calendrier adapté la saisie des prochaines dates de centres détermine les bornes proposées par défaut, au niveau des dates de début et de fin, et du premier et dernier jour de la semaine.

Limites par jour

Lorsque le contrôle des limites par jour est activée, la liste des jours en surnombre est affichée lorsque l'affectation d'un centre de loisirs à un adhérent implique le dépassement autorisé pour le matin, le nombre de repas ou l'après-midi.

Journées récréatives

Tarifs

Dix tarifs peuvent être utilisées pour les journées récréatives. Ils permettent de calculer rapidement le coût d'une activité (même si ces valeurs restent individuellement modifiables lors de la saisie), en fonction d'un tarif jour, matin, après-midi et repas.

Le tarif calculé est effectué par regroupement (hormis pour les repas) maximum pour minimiser éventuellement le coût. Si l'intégralité de la journée est sélectionnée, le tarif jour est appliqué au lieu de l'association matin et après-midi. Si aucun tarif dégressif n'est appliqué, il suffit d'indiquer comme tarif jour la somme matin+après-midi.

Dates prochaines

Pour faciliter la saisie en proposant un calendrier adapté la saisie des prochaines dates, détermine les bornes proposées par défaut, au niveau des dates de début et de fin, et du jour de la semaine.

Limites par jour

Lorsque le contrôle des limites par jour est activée, la liste des jours en surnombre est affichée lorsque l'affectation d'une journée récréative à un adhérent implique le dépassement autorisé pour le matin, le nombre de repas ou l'après-midi.

Base de données

Statistiques de la base

Indique le nombre de fiche dans les différentes tables de la base de données.

Sauvegarde automatique

Si vous disposez d'un disque dur de grande capacité (sur votre machine ou sur un poste accessible par réseau), vous pouvez demander une sauvegarde automatique de la base de données. Cette sauvegarde, qui se lance automatiquement chaque fois que l'application est quittée, effectue une recopie du fichier MJCxxxx.MDB (base de données complète), vers le répertoire désigné ici, soit sous la forme d'un fichier de même nom (l'ancienne sauvegarde étant automatiquement écrasée par la nouvelle), soit la forme d'un fichier dont le nom est constitué de la date (format aaammjj.mdb). Cette dernière méthode permet d'obtenir ainsi de multiples fichiers de sauvegardes jour par jour, assurant une possibilité en cas de problème important, de revenir à une version antérieure peu modifiée : cette méthode a cependant le désavantage "d'encombrer" votre disque de très nombreux fichiers.

Trois répertoires de destination peuvent être prévus, avec priorité :

- si le répertoire principal existe (ou peut être créé dans le cas ou la création est autorisée) ce répertoire est utilisé

- sinon, un essai est fait vers le répertoire de sauvegarde secondaire 1, puis vers le répertoire secondaire 2.

Ces répertoires ont pour fonction de faciliter des sauvegardes sur un réseau local : en effet, si la station de travail est isolée, la sauvegarde ne peut se faire que sur le disque de la station. Mais si la station de travail est membre d'un réseau local, il est envisageable de déporter le fichier sauvegardé vers un autre poste (ce qui assure plus de sécurité en cas de problème matériel sur la station utilisant l'application). Par exemple, il est ainsi possible de demander une sauvegarde prioritaire vers un poste du réseau, puis s'il est éteint ou indisponible lors de la tentative de sauvegarde, de tenter la même opération vers un autre poste, et en fin, en cas d'échec total, de procéder à la sauvegarde (secondaire 2) vers un répertoire du disque de la station.

Note 1 : aucune procédure de restauration automatique n'est prévue. Cette sauvegarde est une simple sécurité. Il appartient donc à l'utilisateur qui désire restaurer une sauvegarde ainsi créée de recopier le fichier concerné vers le répertoire de destination.

Exemple : recopie de C:\SAUVE\20001231.MDB (sauvegarde du 31 décembre 2000) vers C:\MJC\MJC2000.MDB

Note 2 : aucune procédure n'est prévu pour la destruction des fichiers de sauvegarde datés inutiles. L'utilisateur devra donc vider le répertoire de sauvegarde manuellement des sauvegardes jugées inutiles.

Note 3 : l'usage de la sauvegarde automatique ne vous dispense pas d'effectuer des sauvegardes sur d'autres supports. Si cette procédure est rapide, elle ne vous protège par exemple pas des effets d'un problème de panne matériel de disque.

Année courante

Permet de modifier l'année en cours de traitement, pour effectuer des traitements sur la base des années précédentes ou préparer la nouvelle année.

Le changement d'année n'est possible que:

·si la base de l'année existe (les différentes bases dans le répertoire courant indiqué sont recensées dans la liste déroulante)

·ou, si la base de l'année n'existe pas, mais que celle de l'année précédente existe. La nouvelle base est alors créée, avec report des paramètres, des professions, des activités et des communes. Le compteur des adhérents est replacé au millier immédiatement supérieur à la dernière valeur.

Il est possible de choisir de ne pas reprendre les fiches professions, activités et communes qui n'ont pas été utilisée.

Le chemin de l'emplacement de la base de données sur le disque dur ou le réseau est modifiable aussi dans ce module.

Note : il est parfois nécessaire d'utiliser l'accès à la base par "connexion d'un lecteur réseau". L'application effectue alors automatiquement la connexion avec le nom d'utilisateur et le mot de passe indiqué (C'est par exemple le cas lorsque la base est hébergée sur un compte utilisateur en XP Pro protégé par mot de passe, et que l'accès doit se faire à partir d'une machine XP Home).

Autres tables et données

Modes de règlement

25 modes de règlements différents peuvent être gérés par cette table. Pour chaque mode de règlement est indiqué:

- un libellé complet apparaissant dans les boîtes de sélection du mode

- un résumé (texte plus court), qui est indiqué dans le tableau des règlements sur la fiche adhérents.

De plus, l'indication 'Défaut' permet de prépositionner un mode par défaut lors de la création d'un règlement (voir 'Saisie d'un adhérent')

Echéances

La table échéance permet de déclarer toute sorte d'échéances utile lors de la saisie des règlements (ainsi qu'à l'état imprimé récapitulatif permettant de déterminer les remises à l'encaissement nécessaires à une date donnée)

Quelques exemples :

- Comptant : nb jours=0, fin de mois=Non

- 30 jours fin de mois : nb jours=30, fin de mois=Oui

- 60 jours fin de mois le 10 : nb jours=60, fin de mois=Oui, Jour fixe=Oui

- fin de troisième trimestre : nb jours=0, fin de mois=Oui, Mois fixe=9

Numéros

Le compteur du numéro automatique d'adhérent peut être modifié. Il est impossible de donner une valeur inférieure ou égale à un numéro d'adhérent existant. Par exemple, ce module peut permettre après une saisie inadéquate, donc détruite, de repositionner le compteur pour obtenir une suite séquentielle de numéros d'adhérents.

Zones libres

La fiche adhérent comporte neuf zones optionnelles de 40 caractères. L'utilisateur peut définir leur fonction en leur associant un libellé libre par cette option.

Une zone dont le libellé est non vide apparaît sur les masques de saisie, de consultation et de recherche.

La mise à vide d'un libellé entraîne la disparition de l'affichage de cette zone (mais pas l'effacement des valeurs correspondantes si elles existent).

Les zones optionnelles sont aussi reprises par la commande Historique et Famille, ainsi que par le changement d'année.

Il est possible ici
- d'indiquer qu'une zone libre permet l'envoi d'un mail, entraînant l'apparition d'un bouton d'envoi sur la fiche consultation (si la zone libre n'est pas vide et si contenu apparaît comme un email valide), et les traitements des mails en Recherche et Opérations générales.
- d'indiquer qu'une zone libre permet l'envoi d'un SMS, entraînant l'apparition d'un bouton d'envoi sur la fiche consultation (si la zone libre n'est pas vide et si contenu apparaît comme un numéro SMS valide), et les traitements des mails en Recherche et Opérations générales.

- qu'une zone libre ne peut contenir une valeur vide : dans ce cas, tant en saisie qu'en consultation, il est impossible de valider la fiche tant que la zone correspondante reste vide.

Par défaut, l'ensemble des zones libres sont reprises automatiquement par l'usage des boutons "Historique" et "Famille" lors de la saisie. Il est cependant possible ici d'indiquer par simple case à cocher dans la colonne H qu'une zone ne doit pas être reportée sur la nouvelle fiche à partir de la fiche historique, ou par case à cocher dans la colonne F que la zone issue d'une fiche de la même famille ne doit pas être reprise.

Etiquettes

Etiquettes individuelles

Etiquettes sur imprimante ligne

L'impression des étiquettes nécessite un paramétrage précis

De une à huit étiquettes peuvent être imprimées simultanément, en définissant les positions, la taille d'une étiquette et les marges.

Les séquences d'initialisation et de fin correspondent à des chaînes spécifiques à envoyer à l'imprimante avant d'imprimer l(es) étiquette(s), et après cette impression.

Le contenu de l'étiquette doit être détaillé ligne par ligne. Chaque ligne peut contenir jusqu'à trois zones différentes, chacune d'elle disposant:

- d'un alignement spécifique avec G=à gauche, C=centré et D=à droite. Cette option n'a d'intérêt que

si la largeur de la zone est fixe.

- d'une longueur spécifique (par = et indication du nombre de caractères) ou d'un ajustement à la longueur du texte à imprimer (A)

Les rubriques (activités-codes) et (activités-libellé) permettent d'imprimer la liste des activités (à l'exclusion des codes d'adhésions déclarées dans 'Tranches d'âges-Adhésions')

La boîte à cocher Ascii détermine si l'impression doit se faire selon la table de caractères ASCII ou selon la norme ANSI de l'application (permet de résoudre des problèmes lors de l'impression de caractères accentués).

Etiquettes sur imprimante étiqueteuse

Il s'agit ici du paramétrage sur une imprimante gérée par Windows dédiée à l'impression d'étiquettes.
La définition des zones est similaire à celle de l'imprimante ligne, hormis qu'il est possible d'obtenir l'impression des textes trop longs sur plusieurs lignes (option "Multiligne des dépassements").
Si le catalogue internet est géré, avec génération automatique de fiches adhérents, il est possible d'obtenir un QRcode sur l'étiquette donnant accès à l'URL spécifique de l'adhérent sur le site, cadré à droite.

Etiquettes (page)

Choix du format d'étiquettes utilisé pour les impressions en planches A4.

Texte année

Détermine le texte qui doit apparaître sur l'étiquette lors de l'utilisation de la rubrique 'Année'. Par exemple '1994/95 No' si la rubrique année est suivie du numéro d'adhérent.

Divers

Tranches d'âges - Statistiques

Ce module permet de déterminer 20 tranches d'âges utiles à l'édition de la statistique de répartition par âges et par sexe.

Sons

Certaines options sonores peuvent être activées sur une machine disposant d'une carte son (ou d'un driver spécifique simulant une carte son sur le haut parleur) :

- clic sur un bouton

- signal sonore d'erreur.

Si ces options ne sont pas activées seul un bip sonore est généré sur le haut parleur; inversement, l'utilisateur pourra choisir le fichier de son choix au format Wave pour les deux types d'indicateurs sonores.

Monnaie

Ces options vous permettent de paramétrer la gestion des modes francs et euros, en définissant si le système doit travailler en une monnaie unique, ou en double monnaie (dans ce cas, les divers montants peuvent apparaître avec leur équivalents dans la seconde monnaie, ou encore, comme en saisie ou consultation, avec un bouton spécifique permettant de basculer l'affichage d'une monnaie vers l'autre).

Les symboles monétaires choisis peuvent être à un ou deux caractères (FF par exemple).

Attention: le symbole euro n'existe pas systématiquement sur les machines en version Windows 3.11 et 95: un utilitaire spécial peut être requis pour obtenir ce symbole. En windows 98 et ultérieurs, ce symbole est obtenu par la combinaison de touche Ctrl+Alt+E.

L'utilisation de ces options dépend du calendrier que vous avez choisi pour le passage à l'euro : si vous choisissez de commencer l'exercice dans la nouvelle monnaie, modifiez la monnaie avant toute saisie d'adhérents.

Note: si votre nouvel année est créée à partir d'une reprise de l'année antérieure, utilisez le bouton "Changement de monnaie (Recalcul)", qui aura pour effet de recalculer les montants des activités reprises automatiquement.

Si vous choisissez le basculement en cours d'exercice, utilisez le bouton "Changement de monnaie (Recalcul)" qui convertira tous les montants de l'application exprimés en francs en montants en euros.

Attention : la conversion francs->euros étant obtenu par division par 6.55957 arrondie au centime le plus proche (et la conversion euros->francs par multiplication), l'opération n'est pas systématiquement réversible (problème d'arrondi).

Libellé des tarifs

Cette option permet d'affecter un nom aux dix tarifs des activités standard, et d'activer la gestion des tarifs spécifiques (à savoir la liste de sélection d'un tarif spécifique à chaque adhérent sur la fiche adhérent)

Remise spéciale

Cette option permet lors de la saisie d'un adhérent de générer automatiquement un règlement pour le montant indiqué ici, lorsque le code postal de l'adhérent (ou le début du code postal) correspond à celui de la "remise spéciale". Cette option permet par exemple de gérer une participation fixe communale.

Texte année (saison)

Ce texte apparaît notamment sur les factures standards. (il indique la saison : par exemple 2020/2021)

Comptabilité

Interface comptable

Voir Génération comptable

Paramètres comptables

Voir Génération comptable

Facturation

Cette option détermine si le bouton d'édition de facture doit être proposé sur les fiches adhérents, et indique le prochain numéro de facture.

Vous pouvez aussi définir :

·Le texte précédant l'éventuel nom de l'utilisateur sur les factures (par exemple "Vous avez été accueilli par "

·La dénomination exacte du document : par exemple "Facture" ou "Reçu"

Importation et exportation de données

Voir Importation/Exportation

Technique

Paramètres imprimantes

Simplifie la gestion de l'imprimante ligne pour l'impression d'étiquettes, en réseau ou non. Voir Problèmes techniques - Etiquettes.

Config Mail

Config SMS

Excel et Word
L'application peut exporter certaines données vers les applications Microsoft Excel et Word : ce module permet de déclarer définitivement si ces applications existent sur le poste utilisateur, ou si leur présence doit être systématiquement testée au lancement de l'application. Par défaut, ce test est effectué au seul premier lancement de l'application, et non à chaque lancement, pour éviter une perte de temps.

Config FTP

Les icônes complémentaires :
Réparation de la base de données

Mise à jour manuelle de la structure de la base (voir note en Mise à jour de l'application)

Mise à jour de l'application


Génération comptable

Les modules relatifs à la comptabilité ne sont accessibles que si l'interface comptable est activé (par Paramètres Interface_comptable), avec choix d'une exportation vers SYBEL, CIEL, EBP, SAGE ou QUADRATUS.

Export SYBEL

Ce module génère automatiquement un fichier ASCII des écritures comptables pour une intégration automatique dans la comptabilité SYBEL, en fonction des paramètres définis en Paramètres Paramètres_Compta (Voir ci dessous).

Ce module génère automatiquement un fichier ASCII des écritures comptables pour une intégration automatique dans la comptabilité CIEL en fonction des paramètres définis en Paramètres Paramètres_Compta. (Voir ci dessous).

L'opération de génération d'écriture se déroule en 3 phases:

- après sélection de la date de départ (proposée à la dernière date de génération) et de la date de fin (date du jour), l'indication de non génération (ou régénération) des écritures déjà créées entre ces deux dates, et le choix du fichier de destination, l'application calcule les différentes lignes comptables à générer

- une phase de modification des lignes est possible, par double-clic sur la ligne concernée. La ligne peut aussi être détruite.

- la génération des écritures reporte les données du tableau dans un fichier utilisable sous la comptabilité SYBEL, indique sur les activités et les règlements des adhérents concernés que les écritures relatives ont été générées, et note la date de génération.

Attention: le fichier n'est pas forcément immédiatement récupérable en comptabilité, pour des raisons propres au paramétrage de la comptabilité: journal inexistant, comptes inexistants, écritures non équilibrées, nombre d'écritures insuffisant...

Export CIEL

Ce module génère automatiquement un fichier ASCII des écritures comptables pour une intégration automatique dans la comptabilité CIEL en fonction des paramètres définis en Paramètres Paramètres_Compta. (Voir ci dessous).

Le format CIEL utilisé est ASCII, défini dans le logiciel CIEL en UTILITAIRES - IMPORTATION - Format Ciel ASCII

Attention: le seul fichier reconnu en importation est un fichier XIMPORT.TXT implanté dans le répertoire de la société concernée. Si le fichier porte un autre nom, il conviendra de le renommer pour pouvoir l'importer; s'il est généré dans un répertoire autre que celui de la société comptable, il sera nécessaire de le recopier. Le plus simple reste donc de donner à votre fichier le nom complet indiquant le bon répertoire (par exemple: C:\WCPTA\00000000\XIMPORT.TXT pour la société de démonstration Ciel)

L'opération de génération d'écriture se déroule en 3 phases:

- après sélection de la date de départ (proposée à la dernière date de génération) et de la date de fin (date du jour), l'indication de non génération (ou régénération) des écritures déjà créées entre ces deux dates, et le choix du fichier de destination, l'application calcule les différentes lignes comptables à générer

- une phase de modification des lignes est possible, par double-clic sur la ligne concernée. La ligne peut aussi être détruite.

- la génération des écritures reporte les données du tableau dans un fichier utilisable sous la comptabilité Ciel, indique sur les activités et les règlements des adhérents concernés que les écritures relatives ont été générées, et note la date de génération.

La structure du fichier imposée par CIEL est :

- type SDF (sans délimiteur) et la taille d'un enregistrement ne doit pas dépasser 103 caractères.

- structure:

·N° de Mouvement 5 caractères . Numérique (les numéros de mouvements générés sont séquentiels à partir de 1. Le module d'intégration Ciel les adapte automatiquement au dernier numéro réel).

·Journal 2 caractères. Alphanumérique

·Date d'écriture 8 caractères. Format date (AAAAMMJJ)

·Date déchéance 8 caractères. Format date (AAAAMMJJ)

·N° de pièce 12 caractères. Alphanumérique

·Compte 11 caractères. Alphanumérique

·Libellé 25 caractères. Alphanumérique

·Montant 13 caractères.(2 déc.) Numérique

·Crédit-Débit 1 caractère (D ou C)

·N° de pointage 12 caractères. Alphanumérique

·Code analytique/budget 6 caractères. Alphanumérique

·Libellé du compte 34 caractères. Alphanumérique (ZONE FACULTATIVE)

Export EBP

Ce module génère automatiquement un fichier ASCII des écritures comptables pour une intégration automatique dans la comptabilité EBP.

- type fichier ASCII avec séparateur TAB

- structure

·Journal 3 caractères

·Compte

·Montant débit

·Montant crédit

·Libellé

·Date (format jj/mm/aaaa)

·Pièce

·Centre

·Date d'échéance (jj/mm/aaaa)

Export SAGE

Ce module génère automatiquement un fichier ASCII des écritures comptables au format SAGE PNM.

- type fichier ASCII

- structure :

en première ligne le libelle de la comptabilité

puis une écriture par ligne composée de

·code Journal (3 car.)

·Date (format jj/mm/aa)

·Type de pièce (2 car. : FC=Facture Client, RC=Règlement client)

·Compte général (13 caractères)

·Type de compta (1 caractère vide)

·Compte auxiliaire (13 caractères vides)

·Référence de l'écriture (13 caractères vides)

·Libellé de l'écriture (25 caractères)

·Mode de paiement (1 car)

·Date d'échéance (format jj/mm/aa)

·Sens (1 caractère : D=Débit, C=Crédit)

·Montant (20 caractères)

·Type d'écriture (1 caractère N=Normale)

·N° de pièce (7 caractères)

·Zone réservée (25 caractères vide)

·Code Iso de la monnaie (3 caractères EUR)

·Montant en devises (20 caractères vides)

·Code Iso de la devise (3 caractères vides)

·Plan analytique (10 caractères)

·Section analytique (25 caractères)

Export QUADRATUS

Ce module génère automatiquement un fichier ASCII des écritures comptables au format ascii QUADRATUS.

- type fichier ASCII

- structure :

une écriture par ligne composée de 231 caractères avec

·en position 1, sur 1 caractère : lettre M

·en position 2, sur 8 caractères : le numéro du compte

·en position 10, sur 2 caractères : le code journal

·en position 12, sur 3 caractères : un numéro de folio (ici à 000)

·en position 15, sur 6 caractères : la date au format jjmmaa

·en position 42, sur 1 caractère : le sens (D ou C)

·en position 43, sur 13 caractères : le montant en centime (signe en position 43)

·en position 111, sur 3 caractères : le numéro du compte (version Windows seulement)

Les paramètres comptables:

La génération comptable dépend des éléments indiqués dans le module Paramètres Paramètres_Compta.

Pour SYBEL

·Le nom du journal de VENTE (par défaut VENTE)

·Le nom du journal de BANQUE (par défaut BANQUE)

·Le nom du journal de CAISSE. Si le mode de règlement utilisé a un code comptable commençant par 53 (compte caisse du plan comptable général 1982), les écritures générées correspondantes sont affectées à ce journal.

·Le centre analytique standard (par défaut S). Ce centre est exigé par la comptabilité SYBEL. Il n'a d'intérêt que si une comptabilité analytique est nécessaire. Il est alors possible de créer un nouveau centre en comptabilité SYBEL (ex: ADH) et de le déclarer ici pour une affectation analytique automatique.

·Le nom du fichier généré. Ce nom est celui proposé de manière standard par le module de génération des écritures; il reste cependant modifiable par ce dernier module.

Pour CIEL

·Le nom du journal de VENTE (par défaut VT)

·Le nom du journal de BANQUE (par défaut BQ)

·Le nom du journal de CAISSE (par défaut CA). Si le mode de règlement utilisé a un code comptable commençant par 53 (compte caisse du plan comptable général 1982), les écritures générées correspondantes sont affectées à ce journal.

·Le centre analytique standard (par défaut ATE01)

·Le nom du fichier généré. Proposé en standard à XIMPORT.TXT, complétez le par le chemin complet de la société comptable, de manière à ce que le fichier d'intégration soit automatiquement détecté et intégrable.

Pour EBP

·Le nom du journal de VENTE (par défaut VE)

·Le nom du journal de BANQUE (par défaut BQ)

·Le nom du journal de CAISSE (par défaut CA). Si le mode de règlement utilisé a un code comptable commençant par 53 (compte caisse du plan comptable général 1982), les écritures générées correspondantes sont affectées à ce journal.

·Le centre analytique standard (par défaut DIVERS)

·Le nom du fichier généré. Proposé en standard à EBP.TXT.

Pour SAGE

·Le libellé de la comptabilité

·Le nom du journal de VENTE (par défaut VE)

·Le nom du journal de BANQUE (par défaut BQ)

·Le nom du journal de CAISSE (par défaut CA). Si le mode de règlement utilisé a un code comptable commençant par 53 (compte caisse du plan comptable général 1982), les écritures générées correspondantes sont affectées à ce journal.

·Le plan analytique (par défaut DIVERS)

·Le nom du fichier généré. Proposé en standard à STANDARD.PNM.

Pour SAGE

·Le nom du journal de VENTE (par défaut VE)

·Le nom du journal de BANQUE (par défaut BQ)

·Le nom du journal de CAISSE (par défaut CA).

·Le nom du fichier généré. Proposé en standard à QUADRATUS.TXT

Par ailleurs,

- les paramètres de TVA sont communs aux quatre types d'interface comptable: ils permettent de déterminer quatre taux, avec libellé et code d'imputation comptable (Les écritures à taux 0 ne sont évidemment pas générées). La table d'origine indique:

Taux 0 | Non soumis |
Taux 20 | Taux 20 % | Code 44571
Taux 5,5 | Taux 5,5 % | Code 44571
Taux 7 | Taux 7 % | Code 44571

- est commune l'indication "Compte client selon" : code activité, ou code adhérent.

Dans le premier cas, le code client utilisé est celui de la table activité (par exemple le code par défaut 411GYM000 pour le code GYM000), ou un code composé à partir du numéro d'adhérent.

- pour les règlements, la date d'écriture utilisée est celle de la date d'échéance, pour que l'écriture soit enregistrée lors de la remise réelle de la pièce.

Si des centres analytiques ont été attribués aux fiches activités, ces centres analytiques sont utilisés. Pour les activités sans code analytique, le code saisi dans les paramètres comptables est utilisé par défaut.


Opérations générales

Les opérations générales regroupent des traitements relatifs à des ensembles des données :

Pour les activités :

Avoir pour une activité
- Après sélection d'un code d'activité et d'un montant d'avoir, le bouton 'Calculer' génère la table des adhérents concernés.

- En cas de validation, une ligne de règlement est automatiquement générée, avec la date et le libellé général choisi, sur chaque fiche d'adhérent concerné. Il est possible de modifier le montant affecté éventuellement à un ou plusieurs adhérents spécifiques, en modifiant ce montant dans le tableau avant validation.

SMS pour une activité ou des activités

- Après sélection du code activité concerné (ou des activités dont le code est compris entre deux bornes données), sélectionne les n° de SMS des adhérents pour un envoi groupé, propose la saisie d'un message ou la sélection dans la bibliothèque des messages, et transfère les informations à l'expéditeur de SMS.
Un numéro de SMS de test peut être automatiquement ajouté à la liste, afin de tester la bonne réception (ou d'archiver un envoi).

EMAIL pour une activité ou des activités

- Après sélection du code activité concerné (ou des activités dont le code est compris entre deux bornes données), sélectionne les adresses mail des adhérents pour un envoi groupé, propose la saisie d'un message ou la sélection dans la bibliothèque des messages, et transfère les informations à l'expéditeur de Mail.

Pour les adhérents :

Modes de contacts :

Etablit la liste des adhérents selon divers modes de contacts. Chaque adhérent n'apparaît que dans un des quatre tableaux selon l'ordre préféré des modes de contacts. Au delà du menu contextuel accessible sur chaque tableau de mode, un menu spécifique au mode permet copie ou envoi (avec élimination des doublons éventuels)

Exemple pour l'envoi d'une lettre d'information :
1 - On souhaite envoyer à tous les adhérents une lettre d'information par email, en ne limitant l'envoi par courrier qu'aux adhérents ne disposant pas d'une adresse email.
2 - On dispose,
- d'une adresse mail gérée par l'application,
- d'une imprimante permettant l'impression d'étiquettes (étiquettes adhérents, mais donc aussi étiquettes adresses).
- pour un email de qualité au format HTML contenant des images, une adresse URL internet complète (site internet personnel, hébergement temporaire, etc...) d'accès à ces images.
3 - Première étape : la rédaction du message
- Pour le message internet, il convient, s'il contient des images de les insérer sous la forme d'une URL complète assurant leur accès (<img src=...>). Ce message HTML peut être préparé à l'aide de n'importe quel éditeur, y compris l'éditeur intégré de la bibliothèque de message.Au final, le message doit être inséré dans la bibliothèque de message.
Le message HTML peut inclure des champs personnalisés (accessible lorsque l'éditeur est appelé par "html adh") : dans ce cas, les champs sont automatiquement remplacés pour chaque message par les données spécifiques de l'adhérent concerné.
4 - Sélection et envoi des messages
Dans Opération générales, "Modes de contacts", choisir la présentation par "Emails, adresses, SMS, téléphones". Les deux derniers tableaux contiennent, éventuellement, les adhérents qui n'ont ni adresse email ni adresse postale. Pour envoyer le message à tout les destinataires par email, il suffit, dans le menu en haut à droite du premier tableau, de sélectionner la commande "Envoyer un email". La bibliothèque s'ouvre, demandant quel message envoyer : cliquer sur la lettre d'information précédemment créée, et valider. Un email est généré pour chaque adresse email unique, et inséré en file d'attente dans l'expéditeur de mail. Il ne restera plus qu'à démarrer les envois.
5 - Pour les envois par courrier postal, l'entête du second tableau indique combien de documents il vous faut, et la commande "Imprimer des étiquettes" (menu en haut à droite de ce second tableau) permet l'impression directe de chaque adresse sur l'imprimante dédiée.

SMS pour tous les adhérents (assemblée générale) :

Sélectionne les n° de SMS des adhérents pour un envoi groupé, propose la saisie d'un message ou la sélection dans la bibliothèque des messages, et transfère les informations à l'expéditeur de SMS.

Note : sont considérés comme adhérents les inscrits dont une activité est relative à un code figurant dans les tranches d'âges pour adhésion automatique.

Et l'accès à toutes les fonctions du Catalogue Internet.


Outils

Calendrier

Gestionnaire de codes postaux

Le gestionnaire de codes postaux permet de retrouver toutes les communes possédant un code postal donné (ou un début de code postal), ou inversement, de connaître le code postal d'une commune.

La liste des communes ainsi trouvée peut être automatiquement exportée dans la table des communes de l'application MJC.

Note: le bouton Copier transfère aussi cette liste dans le presse-papiers afin de vous permettre de l'exploiter dans n'importe quel autre logiciel par opération de Coller

QRCode Vcard

Affiche le contact de l'adhérent sous forme d'un QR Code lisible par la plupart des smartphones, afin d'ajouter rapidement la fiche aux contacts.

Expéditeurs de SMS et de Mails

Les différents messages groupés à envoyer (mail ou SMS) sont regroupés dans des modules d'expédition qui gèrent l'envoi en arrière plan de l'ensemble des messages pendant l'exécution de l'application, ainsi que la reprise au prochain lancement des envois non effectués.

L'utilisateur peut saisir manuellement un nouveau message dans l'expéditeur, modifier un message existant, ou supprimer un envoi en mettant à vide la zone du destinataire. Il est possible aussi, après sélection d'une ou plusieurs lignes, de faire appel à la bibliothèque de messages pour sélectionner un message préécrit commun.
L'envoi, qui se lance par le bouton [image] , peut être interrompu par clic sur le même bouton devenu [image] .

Bibliothèque de messages

La bibliothèque de message permet de sauvegarder des messages textes fréquents.

Note : pour les mails aussi le format standard des messages est le format texte. Mais si le mode d'envoi choisi est Smtp, le format des messages peut être en html : il suffit alors que le message débute par le début de balise <html ou par <!DOCTYPE html pour que l'envoi ce fasse dans ce format.
Pour cette raison, la saisie du contenu d'un mail se complète de trois boutons spécifiques :
- "text" remet éventuellement en format texte seul un mail au format html,
- "html" appelle l'éditeur html interne pour une saisie évoluée,
- "html adh" appelle l'éditeur html interne pour une saisie évoluée incluant des champs spécifiques à l'adhérents. Attention : ces champs ne sont utilisés que dans le cas d'envoi spécifiques gérés par l'application, comme par exemple les contacts par emails proposés en Opérations générales, ou en consultation (lorsque le mode d'envoi est SMTP). Pour le descriptif complet de ces champs, voir la Fiche Adhérents en Catalogue internet.

Expéditeur FTP

Envoi en arrière plan les documents à transférer en FTP nécessaires au Catalogue Internet.

Envoi d'email individuel

Utilise les paramètres de l'application pour l'envoi d'email quelconque.

Messagerie réseau

Affiche la fenêtre de communication simple entre les utilisateurs du réseau connectés sur la même base de données. Pour envoyer un message à un utilisateur déterminer, il faut simplement sélectionner l'onglet correspondant. Lorsqu'il y a plus d'un autre utilisateur, l'onglet "*" permet d'envoyer le même message à tous les utilisateurs.

Note : la liste des utilisateurs est celle de ceux s'étant connectés à la base lors de la session. Certains utilisateurs qui ne sont plus connectés peuvent donc encore apparaître dans les onglets.


Centres de loisirs et journées récréatives


Gestion des centres de loisirs et des journées récréatives

Par défaut, l'application gère un centre de loisir unique, et un seul lieu de journées récréatives.

L'application est cependant en mesure de gérer automatiquement un nombre quelconque de ces centres ou journées, en

- permettant ainsi les statistiques et état pour un centre ou une journée spécifique

- générant automatiquement les codes CL ou JR lors de la sélection sur grille.

Note : la numérotation des centres ou journées, CL ou JR, a été étendue en base 36 (utilisant des notations 0,1,2... à 9, puis A à Z), plus étendue que la simple numérotation décimale (limitant à 1000 codes différents). Par ce mode de numérotation, l'application sait donc gérer automatiquement 46 656 codes différents d'activités, de CL000 à CLZZZ, et de JR000 à JRZZZ.)

Pour un fonctionnement correct des génération automatique de centres et journées, il est nécessaire en cas de plusieurs centres ou journées, de répartir les codes disponibles en tranches de codes possibles.

Exemple : l'écran ci-dessous présente un cas théorique avec 3 centres

Descriptif des colonnes

- 1 - Libellé = Nom du centre (modifiable par saisie après clic), tant pour centre de loisirs, que pour journée récréative

- 2 - CL = case à cocher (modifiable par double clic), indiquant si le centre comprend un centre de loisirs

- 3 - et - 4 - De... à = tranches de codes, pour la génération des codes CL

- 5 - Colonne informative : calcule le nombre de codes automatiques disponibles dans la tranche

- 6 - JR = case à cocher (modifiable par double clic), indiquant si le centre comprend une journée récréative

- 7 - et - 8 - De... à... = tranches de codes, pour la génération des codes JR

- 9 - Colonne informative : calcule le nombre de codes automatiques disponibles dans la tranche

Dans l'exemple ci dessus, on a

- trois centres de loisirs, indiqué respectivement avec les tranches 000 à 9ZZ, A00 à CCC, et BBB à ZZZ. La validation est impossible, car, comme on le voit sur la ligne graphique représentant la répartition des codes CL, deux tranches (en rouge) se chevauchent (tranche BBB à CCC, commune à 2 et 3).

- un centre pour journée récréative, Centre 2, utilisant toutes les tranches possibles.


Journées récréatives

La grille de saisie

La grille ne permet pas de gérer des périodes supérieures à 52 semaines consécutives.

La sélection des jours concernés peut être faite de multiples façons:

·Sélection individuelle:

Un clic sur l'une des cases (curseur flèche) sélectionne ou désélectionne l'élément.

·Sélection par zone: pour sélectionner une zone, lorsque le curseur est une croix, cliquez sur la souris et déplacez le curseur jusqu'au point final de la zone avant de relâcher le bouton.

Si le bouton gauche de la souris a été utilisé: sélection

Si le bouton droit a été utilisé: désélection

Seuls les éléments intégralement recouverts par la zone de sélection sont pris en compte.

Le bouton [image] permet le basculement de la grille pour une saisie plus rapide d'événements particuliers.

Le prix est automatiquement calculé par regroupement maximum des éléments en journée. Le recalcul est automatique en cas de changement d'une sélection, ou des paramètres de périodes, de semaine ou de prix.

Note sur la numérotation automatique : lors de la sélection sur grille l'application propose la automatiquement la création d'une journée récréative si aucun code existant n'utilise les mêmes caractéristiques exactes. Ces codes commencent par JR, suivi d'un "numéro" séquentiel (voir Gestion des centres de loisirs et des journées récréatives)


Centres de loisirs

La grille de saisie

La grille ne permet pas de gérer des périodes supérieures à 70 jours consécutifs.

La sélection des jours concernés peut être faite de multiples façons:

·Sélection individuelle:

Un clic sur l'une des cases (curseur flèche) sélectionne ou désélectionne l'élément.

·Sélection d'un même jour sur la période:

Clic sur le libellé du jour avec le bouton gauche de la souris: sélection

Clic sur le libellé du jour avec le bouton droit de la souris: désélection

·Sélection par zone: pour sélectionner une zone, lorsque le curseur est une croix, cliquez sur la souris et déplacez le curseur jusqu'au point final de la zone avant de relâcher le bouton.

Si le bouton gauche de la souris a été utilisé: sélection

Si le bouton droit a été utilisé: désélection

Seuls les éléments intégralement recouverts par la zone de sélection sont pris en compte.

Une association judicieuse des zones de sélection permet de saisir rapidement les informations (par exemple, pour une semaine sans repas, on peut tout aussi bien sélectionner les matins de la semaine puis les après-midi, que sélectionner tous les jours et désélectionner les repas).

Le bouton [image] permet le basculement de la grille pour une saisie plus rapide d'événements particuliers: par exemple, pour une sélection de matin tous les lundis, basculer la grille permet une sélection par zone au lieu de la sélection individuelle de chaque matin.

Le prix est automatiquement calculé par regroupement maximum des éléments en semaine, puis en journée. Le recalcul est automatique en cas de changement dune sélection, ou des paramètres de périodes, de semaine ou de prix.

Note sur la numérotation automatique : lors de la sélection sur grille l'application propose automatiquement la création d'un centre de loisir si aucun code existant n'utilise les mêmes caractéristiques exactes. Ces codes commencent par CL, suivi d'un "numéro" séquentiel (voir Gestion des centres de loisirs et des journées récréatives)


Paramètres avancés et aspects techniques

·Editeur de certificats

·Importation/Exportation de données

·Mise à jour

·Déploiement automatique

·Email et SMS

·Pdf

·Messagerie : MAPI ou SMTP ?

·Problèmes techniques

·Installation en réseau

·Réseau virtuel privé (VPN)

·Réparation de la base

·Structure de la base de données


Editeur de certificats

Cet éditeur a pour fonction de définir le contenu des certificats pour

- une activité,

- un stage,

- un centre de loisirs,

- une journée récréative.

- un courrier libre, qui peut néanmoins si nécessaire faire référence à un code activité donné.

Note : dans les versions antérieures à la 6.1.2, les certificats sont dans un format interne (d'extension .MJC) dans le répertoire de l'application. A compter de la version 6.1.2, ils sont dans un format RTF (Rich Text File), donc modifiables soit par l'éditeur intégré, soit par tout autre traitement de texte supportant le format RTF. Les anciens format son automatiquement convertis par l'éditeur en nouveaux formats : quelques adaptations peuvent être nécessaires.

Ces certificats peuvent être imprimés individuellement en saisie ou consultation d'un adhérent (bouton 'Autres impressions'), ou pour un ensemble d'adhérents en Impressions.

L'utilisateur peut intégralement définir la forme des différents certificats grâce à l'éditeur intégré. Après sélection du certificat concerné, l'utilisateur peut en modifier le texte et la forme.

Les différentes zones que l'on peut intégrer sont présentées pour chaque type de certificat dans la liste haut-gauche de l'écran. Un simple clic sur un libellé entraîne le placement de la zone dans le texte. L'utilisateur peut s'il le désire saisir ces zones manuellement mais la moindre erreur dans le libellé fera apparaître ce texte dans le document et non l'information correspondante de la base de données.

Note : la mise en forme adoptée pour toute la zone est celle définie pour le premier caractère de la zone.

En quittant l'éditeur ou en changeant de certificat, la sauvegarde est automatiquement proposée lorsqu'une modification a été apportée au document.

Il conviendra de définir des marges d'imprimante appropriées à l'aspect désiré et aux caractéristiques de l'imprimante.

Note : voir aussi problèmes techniques pour information complémentaire

Gras : alterne le mode caractère gras/caractère normal du texte sélectionné

Italique : alterne le mode caractère italique/caractère normal du texte sélectionné

Souligné : alterne le mode caractère souligné/caractère normal du texte sélectionné

Barré : alterne le mode caractère barré/caractère normal du texte sélectionné

Majuscules minuscules : alterne les trois modes minuscules/majuscules première lettre/ majuscules du texte sélectionné

Cadrage à gauche : alignement à gauche du paragraphe (sur retrait à gauche)

Cadrage au centre : alignement au centre du paragraphe (entre le retrait à gauche et la marge droite)

Cadrage à droite : alignement à droite du paragraphe (sur la marge droite)

Justification du texte : justifie le paragraphe (incompatible avec certains éditeurs de texte)

Puce : insère une puce en début de paragraphe

Diminue le retrait à gauche d'une unité (centimètre ou pouce selon les options)

Augmente le retrait à gauche d'une unité (centimètre ou pouce selon les options)

Couleur du texte sélectionné

Insère un tableau (maximum 255 lignes et 255 colonnes) avec largeur de colonnes ajustées à la fenêtre ou exprimée en centimètres

Image : Insertion d'une image incorporée au fichier RTF

Impression : impression test

Police : sélection de la police de caractères du texte sélectionné

Taille : taille de la police de caractères du texte sélectionné

Taille : augmente ou diminue de la taille la plus proche, la police de caractère du texte sélectionné

Liste par document des zones intégrables :

 | CERTIFICATS
 | Activités | Stages | Centres de loisirs | Journées récréatives | Texte libre
No_adhérent | x | x | x | x | x
Genre | x | x | x | x | x
Part._passé_selon_genre | x | x | x | x | x
Nom | x | x | x | x | x
Prénom | x | x | x | x | x
Rue1 | x | x | x | x | x
Rue2 | x | x | x | x | x
Code_postal | x | x | x | x | x
Ville | x | x | x | x | x
Téléphone_1 | x | x | x | x | x
Téléphone_2 | x | x | x | x | x
Montant_restant_du | x | x | x | x | x
Date_de_naissance | x | x | x | x | x
Libellé_zone_libre_1 | x | x | x | x | x
Libellé_zone_libre_2 | x | x | x | x | x
Libellé_zone_libre_3 | x | x | x | x | x
Libellé_zone_libre_4 | x | x | x | x | x
Libellé_zone_libre_5 | x | x | x | x | x
Libellé_zone_libre_6 | x | x | x | x | x
Libellé_zone_libre_7 | x | x | x | x | x
Libellé_zone_libre_8 | x | x | x | x | x
Libellé_zone_libre_9 | x | x | x | x | x
Zone_libre_1 | x | x | x | x | x
Zone_libre_2 | x | x | x | X | x
Zone_libre_3 | x | x | x | X | x
Zone_libre_4 | x | x | x | X | x
Zone_libre_5 | x | x | x | X | x
Zone_libre_6 | x | x | x | X | x
Zone_libre_7 | x | x | x | X | x
Zone_libre_8 | x | x | x | X | x
Zone_libre_9 | x | x | x | X | x
Code_activité1 | x | x | x | X | x
Code_activité2 | x | x | x | X | x
Code_activité3 | x | x | x | X | x
Code_activité4 | x | x | x | X | x
Code_activité5 | x | x | x | X | x
Code_activité6 | x | x | x | X | x
Lien_code_activité1 | x | x | x | X | x
Lien_code_activité2 | x | x | x | X | x
Lien_code_activité3 | x | x | x | X | x
Lien_code_activité4 | x | x | x | X | x
Lien_code_activité5 | x | x | x | X | x
Lien_code_activité6 | X | x | x | X | x
Code_activité | X | X | X | X |
Libellé_de_l'activité | X | X | X | X |
Animateur | X | X | X | X |
Lieu | X | X | X | X |
Description | X | X | X | X |
Jour_1 | X |  |  |  |
Heure_début1 | X |  |  |  |
Heure_fin1 | X |  |  |  |
Jour_2 | X |  |  |  |
Heure_début2 | X |  |  |  |
Heure_fin2 | X |  |  |  |
Jour_3 | X |  |  |  |
Heure_début3 | X |  |  |  |
Heure_fin3 | X |  |  |  |
Jour_4 | X |  |  |  |
Heure_début4 | X |  |  |  |
Heure_fin4 | X |  |  |  |
Jour_5 | X |  |  |  |
Heure_début5 | X |  |  |  |
Heure_fin5 | X |  |  |  |
Nombre_d'inscrits | X | x | x | x |
Nombre_maximum | X | x | x | x |
Nombre_minimum | X | x | x | x |
Nombre_de_places_disponibles | X | x | x | x |
Date_de_début |  | x | x | x |
Nombre_de_matins |  |  | x | x |
Nombre_de_repas |  |  | x | x |
Nombre_d'après-midi |  |  | x | x |
Date_de_fin |  | x | x | x |
Montant_activité | x |  |  |  |
Montant_stage |  | x |  |  |
Montant_centre |  |  | x |  |
Montant_journée |  |  |  | x |
Prix_tarif1 | x | x | x | x |
Prix_tarif2 | x | x | x | x |
Prix_tarif3 | x | x | x | x |
Prix_tarif4 | x | x | x | x |
Prix_tarif5 | x | x | x | x |
Prix_tarif6 | x | x | x | x |
Prix_tarif7 | x | x | x | x |
Prix_tarif8 | x | x | x | x |
Prix_tarif9 | x | x | x | x |
Prix_tarif10 | x | x | x | x |
Nom_MJC | x | x | x | x | x
Rue1_MJC | x | x | x | x | x
Rue2_MJC | x | x | x | x | x
Code_postal_MJC | x | x | x | x | x
Ville_MJC | x | x | x | x | x
Telephone_MJC | x | x | x | x | x
Telecopie_MJC | x | x | x | x | x
Responsable_MJC | x | x | x | x | x
Fonction_responsable_MJC | x | x | x | x | x
Complement_entete1_MJC | x | x | x | x | x
Complement_entete2_MJC | x | x | x | x | x
Date_du_jour | x | x | x | x | x


Importation/Exportation de données

Les fonctions d'exportation/importation permettent principalement l'utilisation de l'application sur des postes non reliés en réseau, en assurant entre postes la cohérence des tables (activités, communes...) et le rapatriement des saisies effectués.

Elles concernent :

- les activités : les activités inconnues sont automatiquement créées, et en cas de modification le remplacement est proposé.

- les communes : les communes inconnues sont automatiquement créées et en cas de modification, le remplacement est proposé.

- les professions : les professions inconnues sont créées et en cas de modification, le remplacement est proposé.

- les modes de règlement

- les fiches adhérents : lors de l'exportation depuis un poste, seules sont concernées les fiches adhérents sans activités ni règlements, et les fiches adhérents dont l'inscription à une activité ou un règlement est intervenu dans l'intervalle de date déclaré. La date de dernière exportation sert de date de départ à cet intervalle.

La procédure d'importation détecte les fiches déjà existantes ou modifiées et :

- crée automatiquement les fiches nouveaux adhérents en leur réaffectant si nécessaire un nouveau numéro

- propose le remplacement d'une fiche modifiée par les nouveaux éléments

- en cas d'incompatibilité entre les tables des communes et des professions, propose le remplacement des codes concernés par les nouveaux éléments : cette proposition est faite une seule fois par code, un refus étant considéré comme valable pour toute l'importation.

Attention: l'importation ne peut se faire de manière cohérente que si les tables des activités et des modes de règlements ont été harmonisées sur les postes concernés.


Mise à jour

Dans le menu "? - Mise à jour", le bouton "Rechercher une nouvelle version (client)" permet d'interroger un site distant sur l'existence d'une nouvelle version disponible. Si cette mise à jour est disponible, l'application est automatiquement récupérée, puis automatiquement remplacée et relancée.

De manière moins fréquente, les états imprimés peuvent évoluer. Ces états sont implantés sur le serveur, dans le répertoire où se situe la base de données. Ils sont mis en place lors d'une installation complète, mais ne sont pas contenu dans la mise à jour (automatique ou manuelle) de l'application (client). Le bouton "Mettre à jour les états imprimés (serveur)" permet de remettre à jour ces états sur le serveur à partir d'un poste client.

Pour activer la mise à jour (manuelle ou automatique), il est nécessaire de disposer :
- d'une adresse de site de mise à jour
- d'un nom d'utilisateur
- d'un mot de passe

Les champs nom d'utilisateur et mot de passe ne peuvent être vides : si le site de mise à jour ne nécessite pas un nom d'utilisateur ou un mot de passe, il convient cependant de renseigner ces champs par une valeur quelconque.

L'adresse du site de mise à jour peut être aussi bien une adresse de type http:// pour la mise à jour internet qu'une adresse locale de type file:// , permettant ainsi à un groupe d'utilisateurs de partager des paramètres.

Note : la structure de la base peut être amenée à évoluer avec les versions. Ainsi, à chaque téléchargement d'une nouvelle version, la base de données courante évolue automatiquement vers la structure la plus récente. Au cas où cette évolution automatique aurait failli pour une raison quelconque, l'utilisateur peut déclencher une évolution "manuelle" de la base courante dans le menu Paramètres. La même fonction permet de contrôler et assurer l'évolution de toutes les bases de données des différentes années présentes dans le répertoire.


Déploiement automatique

Cette fonctionnalité ne concerne que les installations multipostes en réseau.

Le déploiement sur le réseau, à savoir la mise en place d'une nouvelle version de l'exécutable MJC.EXE sur l'ensemble des postes, est automatique à compter de la version 4.24 de l'application.

Grâce à ce système, seul le poste serveur doit être mis à jour pour entraîner la mise à jour des postes utilisateurs.
La mise à jour d'un poste utilisateur peut donc être assurée :

- soit par la mise à jour automatique , si le poste est relié à internet,

- soit par ce système de déploiement, seul le poste serveur devant alors être connecté à internet.


Email et SMS

L'application intègre :
- l'envoi possible direct d'emails au format texte, même sans logiciel de messagerie installé

- l'envoi possible de SMS par un modem SMS externe (téléphone, modem USB, modem série, etc)

- la gestion d'une bibliothèque de messages, afin de faciliter les messages répétitifs

Configuration pour les emails

Pour permettre l'envoi d'emails, l'utilisateur doit
- indiquer pour les fiches adhérents, quelles zones libres sont susceptibles de contenir l'adresse email ;
- disposer d'un compte de messagerie. Ce compte peut être géré par le gestionnaire de courrier Mapi (outlook 2000, etc...) ou grâce aux paramètres directs du SMTP (voir Messagerie : MAPI ou SMTP ?). La solution préconisée est la solution par SMTP, qui ne nécessite aucun logiciel (l'application sait par ailleurs gérer les SMTP nécessitant une authentification spéciale, tels ceux d'Orange).

Si l'envoi est paramétré en SMTP, l'envoi depuis l'écran Consultation est fait par défaut (à moins que l'utilisateur n'opte volontairement pour le 'mode classique') en mode simplifié par l'expéditeur d'email, permettant l'accès rapide à la bibliothèque de message ; dans ce mode, les messages de la biliothèque peuvent avoir été créée par l'éditeur html interne ("html adh") proposant une saisie évoluée incluant des champs spécifiques à l'adhérent.

Sur une machine ne disposant d'aucune possibilité d'envoi de mail, il est conseillé de désactiver toutes les fonctions d'envoi pour éviter de surcharger les pages et menus de commandes inutiles.

Gestion des envois

Les envois sont de deux types :
- soit individuel, lors de la consultation d'une fiche adhérent (par simple clic sur l'icône d'envoi associée à la zone libre concernée), soit lors de l'envoi d'un état imprimé par Mail sous la forme de fichier PDF.
- soit par envoi groupé (sur des recherches, ou pour une activité ou tous les adhérents dans les opérations générales), qui utilise l'expéditeur d'email.

L'envoi individuel permet aussi la gestion du :
- Carnet d'adresses : Si le système le permet (version Outlook 2000 par exemple et autres clients Outlook), l'application permet de sélectionner directement l'adresse dans le carnet de la messagerie. Si plusieurs adresses sont cliquées dans la liste, elles sont automatiquement cumulées dans la zone adresse, séparées par de points-virgules.
- Carnet spécifique : L'application possède son propre carnet d'adresses, que l'utilisateur peut créer et gérer au sein même de l'application (à l'aide du menu contextuel obtenu par le bouton droit de la souris lorsque le carnet spécifique est ouvert). Le carnet spécifique peut comprendre des adresses simples, mais aussi des listes d'adresses (en indiquant en un même bloc l'ensemble des adresses emails séparées par des points-virgules). Ce carnet spécifique, qui n'est partagé avec aucune autre application, peut être créé manuellement ou à l'aide de l'importation depuis le carnet d'adresses (si plusieurs adresses sont cliquées dans la liste du carnet d'adresses, elles sont automatiquement cumulées dans la zone adresse, séparées par des points-virgules.)
Par ailleurs, le carnet d'adresse spécifique permet d'indiquer une adresse (ou une liste d'adresses) par défaut :cette adresse (ou liste) est systématiquement proposée au lancement de l'écran d'envoi par messagerie, mais aussi, lorsque le carnet spécifique est ouvert puis refermé sans y avoir sélectionné d'élément, et que la zone adresse est vide.

Configuration pour les SMS

Pour permettre l'envoi de SMS, l'utilisateur doit disposer d'un modem spécifique GSM (généralement équipée d'une carte SIM) ou d'un téléphone, relié à l'ordinateur et géré comme un port série.

Sur une machine ne disposant d'aucune possibilité d'envoi de sms, il est conseillé de désactiver toutes les fonctions d'envoi pour éviter de surcharger les pages et menus de commandes inutiles.

Tous les messages SMS sont gérés par l'Expéditeur de SMS.
La norme d'un message SMS est de 160 caractères maximum : par ailleurs, afin d'assurer la plus complète compatibilité, les SMS sont expédiés en format GSM, norme qui limite les caractères disponibles à :
£$¥èéùìòÇ Øø Åå_ ^{}\[~]|€ÆæßÉ!"#¤%&'()*+,-./0123456789:;<=>?¡ABCDEFGHIJKLMNOPQRSTUVWXYZÄÖÑÜ§¿abcdefghijklmnopqrstuvwxyzäöñüà

Les caractères non présents, tels que ç, â, ê, ï, ô,û sont respectivement remplacés par c, a, e, i, o, u.

Note : la plupart des ordinateurs ne disposent plus de port série, et les connecteurs vers téléphones ou modem GSM sont souvent de type USB. Mais le protocole SMS étant un protocole série, il nécessite l'installation automatique d'un driver effectuant une redirection de port. Quel valeur de port COM utiliser ? Le plus simple est dans le Gestionnaire de Périphérique du panneau de configuration de Windows, de consulter non la liste des ports, mais de rechercher le numéro de port dans la rubrique MODEM (souvent en Paramètres avancés - Paramètres avancés du port).

- Simuler l'envoi SMS sur le serveur : cette fonction permet d'organiser l'envoi des SMS depuis certaines machines seulement. Si la simulation est active, les SMS à éventuellement envoyer ne sont pas directement transmis par la machine, mais notés comme à transférer, et sont alors envoyés par les machines du réseau où est activée la fonction d'envoi ("Traiter les simulations").

- Simulation SMS : lorsque cette option est activée, tout comme le transfert SMS, le poste surveille, selon le délai indiqué, les SMS créés ou modifiés par les autres postes en mode simulation, et en assure le transfert SMS. Ce système permet ainsi de consacrer un seul poste du réseau à l'envoi de SMS, sans ainsi ralentir les autres postes ou installer un modem SMS sur chaque poste. Il est même envisageable de dédier ainsi un poste peu utilisé à cette seule opération de transfert.

- Préfixe SMS : précise les préfixes de numéro permettant l'envoi de SMS (par défaut, 06). La liste des préfixes pourra être complétée ultérieurement en séparant chaque préfixe par un /

- Test du port COM au démarrage : si le modem SMS est configuré sur un port COM, ce test optionnel permet de tester sa présence sur ce port au lancement de l'application. S'il fait défaut, un message d'erreur est affiché.

- Le nombre d'essai en cas de non réponse est le nombre de fois où l'application va tenter de relancer la connexion au modem lorsque la tentative a échouée (souvent pour des appels trop rapprochés).


Pdf

Le module d'impression des états permet de diriger l'état vers
- l'imprimante,
- l'écran,
- un fichier de format déterminé (Enregistrement bloqué, Séparateur Tab, Ascii séparateur espace, DIF, CSV séparateur, Ascii séparateur Tab, Crystal Report RPT, Excel 2.1 XLS, Excel 3.0 XLS, Excel 4.0 XLS, Lotus 1-2-3 WK1, Lotus 1-2-3 WK3, Lotus 1-2-3 WKS, Quattro pro 5.0 WB1, RTF, Word pour DOS, Word pour Windows, Wordperfect)
- une adresse de messagerie sous forme d'un fichier PDF.

La mise en place de cette fonction nécessite cependant une application complémentaire, capable de générer un fichier postcript puis de le transcrire en format PDF (comme par exemple l'application Ghostscript disponible sur http://sourceforge.net/projects/ghostscript/ sous la forme d'un package d'exécutable pour Windows), et de divers paramétrage.

Dans la cas de Ghostscript prenons l'exemple de la distribution 8.60 (gs860w32.exe)

1) Installer gs860w32.exe

2) Recopier gsdll32.dll (présent dans le répertoire \bin de ghostscript, donc généralement en c:\program files\gs\gs8.60\bin) dans le répertoire de l'application

3) Installer l'imprimante postscript :
a) Dans le panneau de contrôle de, sélectionner "Imprimantes et télécopieurs", "Ajouter une imprimante","Imprimante locale", "Utiliser le port FILE: 'impression dans un fichier)", "Disque fourni..."
b) Sélectionner le répertoire contenant Ghostpdf.ppd et Ghostpdf.inf (généralement en c:\program files\gs\gs8.60\lib), sélectionner Ghostpdf, remplacer si nécessaire le driver existant, etc...
c) Après l'installation, dans le menu "Paramètres" puis "Imprimante et télécopieurs de Windows, puis dans les propriétés de Ghostscript PDF, sous l'onglet "Paramètres du périphérique", indiquer pour "Taille minimale de police à télécharger en tant que police vectorielle" la valeur "0 pixels"

Il reste, lors d'une demande d'impression à accéder après sélection de "Pdf Mail" à "configuration" :
- dans la boîte de sélection d'imprimante postscript, sélectionner "Ghostscript PDF"
- les zones destinataires; objet et contenu sont des zones permettant de prédéfinir un contenu pour tous les envois. Ces zones peuvent rester vierges
- définir enfin le mode d'envoi (voir paramétrage de la messagerie)
- choisir si chaque envoi de mail successif doit être inscrit doit en fichier smptlog.log sous la forme d'une ligne par envoi (date-heure + destinataire + nom de la pièce)


Messagerie : MAPI ou SMTP ?

L'application peut permettre l'envoi automatique par messagerie avec diverses options, selon deux protocoles, MAPI et SMTP : sur certaines machines seul SMTP peut être disponible. Lorsque les deux protocoles sont accessibles, le choix se fait par le bouton en haut à gauche de la fenêtre "Envoi par messagerie".

 | Protocole MAPI | Protocole SMTP
Disponibilité | Uniquement si un logiciel de messagerie supportant Outlook Automation est disponible | Toujours disponible
Carnet d'adresse | Uniquement si un logiciel de messagerie supportant Outlook Automation est disponible | Uniquement si un logiciel de messagerie supportant Outlook Automation est disponible
Carnet spécifique | Toujours disponible | Toujours disponible
Possibilité de différer l'envoi | Toujours | Non: nécessite d'être connecté pour envoyer le message
Possibilité de conserver trace du message envoyé | Oui | Non (hormis bien entendu si l'utilisateur choisit d'indiquer sa propre adresse dans les destinataires du message)
Envoi par Email anonyme | Non | Oui
Format texte ou HTML | Format texte uniquement | Texte ou Html

MAPI

Attention : Cette possibilité de messagerie ne concerne que les ordinateurs gérant l'automation Outlook, c'est à dire équipés par exemple de Outlook 97, Outlook 2000 ou XP. La version allégée Outlook Express ne permet pas cette gestion.

L'application utilise le logiciel de messagerie installé par défaut, en plaçant les messages dans la boîte d'envoi, mais ne procède pas à l'envoi réel direct du message.

SMTP

Il n'est pas nécessaire de disposer d'un logiciel de messagerie installé sur la machine, L'application gérant seul les protocoles nécessaires !

Pour un fonctionnement correct, il convient de configurer (par le bouton "Configurer SMTP" dans la barre de titre de la fenêtre "Envoi par messagerie" en indiquant le serveur SMTP à utiliser. Il est possible d'indiquer n'importe quelle adresse email (même inexistante, mais dans ce cas le destinataire ne pourra pas répondre).

Par défaut, lors de la configuration, le serveur et l'email par défaut sont automatiquement proposés.

Destinataire : indique l'email du correspondant, ou les différentes adresses séparées par un point-virgule.
Note : les envois de messages multiples se font toujours en copies cachées ; chaque destinataire ignore donc les autres destinataires du message.

Objet : objet du message, proposé par défaut au nom de la fiche concernée.

Contenu : contenu libre. Si les 6 premiers caractères du message présentent les caractéristiques d'une balise html (début par <html, <HTML, <!DOCTYPE html ...), le message est envoyé en format HTML, et en format texte sinon.

Pièce attachée : par défaut, l'envoi inclut le fichier en pièce attachée. Décocher cette option permet de ne pas joindre la pièce attachée au message.

Nom de la pièce attachée : proposée par défaut au nom de la fiche concernée.

Envoi immédiat : lorsque cette option (disponible uniquement en interface MAPI) est cochée, le message est envoyé sans contrôle à la boîte d'envoi du logiciel de messagerie. Si cette option n'est pas cochée, la fenêtre de création de message de l'application de messagerie s'ouvre lors de la création du message, permettant de différer son envoi, de le modifier ou encore de le supprimer.

L'application permet d'accéder au carnet d'adresses ou à un carnet spécifique à l'application pour y sélectionner les adresses.


Problèmes techniques

Plate-forme

L'application est fournie en code 32 bits, ce qui garantit son fonctionnement sur les systèmes suivants :

Windows 95

Windows 98 et 98SE

Windows 2000

Windows NT

Windows XP (Home et Pro)

Windows Vista (Home et Pro)

Windows Seven (Home et Pro)
Windows 8

Windows 10

L'affichage minimum utilisable est un mode 640 x 480, mais une résolution supérieure est préconisée.

Base de données

Les bases de données sont au format ACCESS 2, assurant ainsi son exploitation possibles par des logiciels déjà ancien. Elles se nomment MJCannée.MDB (par exemple MJC2010.MDB pour l'année 2010).

L'année en cours d'utilisation est indiquée dans le fichier MJC.AN sous forme de quatre chiffres (ex: 2010).

Le chemin permettant d'accéder à la base est dans CHEMIN.MJC (utile pour indiquer l'emplacement de la base de données sur le réseau) : ce chemin peut être modifié directement en changeant le contenu de ce fichier, ou en utilisant le menu PARAMETRES - Année courante.

Etiquettes sur imprimante ligne

La structure des étiquettes est dans ETIQ.MJC

L'impression des étiquettes pose un problème particulier: en effet, WINDOWS ne sait pas gérer les imprimantes lignes (*), de sorte qu'il est impossible d'utiliser une programmation directe sous WINDOWS pour l'impression des étiquettes, et encore moins d'opérer directement sur une imprimante simplement déclarée sur le réseau.

(*) Le système d’impression utilisé par Windows est adapté au mode graphique, avec composition de la page complète, puis impression avant éjection. Il est donc impossible de procéder à la seule impression d’une partie de la page sans éjecter. Par ailleurs, ce mode d’impression est adapté à des imprimantes de type jet d’encre ou laser, qui impriment sur page complète, mais ne permettent pas de prendre connaissance d’une partie d’une contenu avant éjection, et encore moins de détacher une étiquette..

C'est pour cette raison que la solution suivante a été adoptée:

1 - Le poste sur lequel est située l'imprimante ligne reçoit les fichiers à imprimer, et scrute régulièrement leur présence afin de lancer l'édition. Il est donc nécessaire que l’application tourne sur cette machine (en avant ou arrière-plan) pour que les impressions puissent se faire.

2 - Les autres postes ne font qu'émettre des fichiers à imprimer vers le poste disposant de l'imprimante. Ce poste doit donc être accessible sur le réseau (donc si nécessaire déclaré serveur), ainsi que le disque qui contient l’application (qui doit alors porter un nom d’unité spécifique). La déclaration se fait dans le fichier ETCHEMIN.MJC avec les indications suivantes:

CHEMIN pour l'écriture du fichier

NOM du fichier

DELAI pour le scrutateur en 100èmes de secondes (0 pour les postes distants)

NOM du fichier à scruter

PROGRAMME à lancer pour l'impression du fichier scruté

Le poste principal édite selon la procédure définie en IMPRETIQ.BAT.

Exemple de solution à deux postes:

Poste principal (application en C:\MJC\ accessible sur réseau E:\MJC\)

·IMPRETIQ.BAT

programme d’impression des étiquettes pour le poste principal

TYPE ETSPOOL.MJC>PRN

·IMPRETI2.BAT

programme d’impression des étiquettes émises par un terminal

TYPE ETSPOOL2.MJC>PRN

·ETCHEMIN.MJC

Déclaration des noms de fichier et de contrôle des demandes du terminal

(ligne vide pour le chemin)
ETSPOOL.MJC(nom du fichier carte principal)
800(délai de 8 secondes)
ETSPOOL2.MJC(nom du fichier émis par le terminal)
IMPRETI2.BAT(procédure d’impression pour terminal)

Poste secondaire

·ETCHEMIN.MJC

Déclaration des noms de fichier et invalidation des contrôles

E:\MJC (destination du fichier)

ETSPOOL2.MJC (nom du fichier émis)

0 (invalidation des contrôles)

Note : si la machine qui détecte l’impression des cartes est sous Windows 95/98/2000/NT4, il est possible que les tâches d’impression (du type IMPRETIQ.BAT) soient exécutées dans une fenêtre qui s’ouvre et reste présente à l’écran après exécution, d’où accumulation des fenêtres inutiles et indications de tâches terminées sur la barre. Pour corriger ce problème, cliquez sur l’une des icônes concernées de la barre de tâche avec le bouton droit de la souris ; dans les propriétés de la tâche (onglet programme), sélectionnez ‘Réduite’ pour Exécuter, et cochez ‘Fermer en quittant’.

Etiquettes sur imprimante ETIQUETEUSE

La structure des étiquettes est dans ETIQI.MJC. Si l'imprimante doit être partagée sur le réseau, il faut l'ajouter sur chaque poste de manière classique comme une imprimante Windows.

Certificats

Les certificats créés par l'éditeur sont sauvegardés dans le répertoire où se situe la base de données, sous les noms:

 | Format antérieur à la version 6.1.2 format interne | Format à partir de la version 6.1.2 format RTF
activités | CERTIF1.MJC | CERTIF1.RTF (texte RTF) et CERTIF1.RT2 (marges)
stages | CERTIF2.MJC | CERTIF2.RTF (texte RTF) et CERTIF2.RT2 (marges)
centres de loisirs | CERTIF3.MJC | CERTIF3.RTF (texte RTF) et CERTIF3.RT2 (marges)
journées récréatives | CERTIF4.MJC | CERTIF4.RTF (texte RTF) et CERTIF4.RT2 (marges)
texte libre | CERTIF5.MJC | CERTIF5.RTF (texte RTF) et CERTIF5.RT2 (marges)

Note : les anciens formats sont automatiquement reconvertis à l'ouverture de l'éditeur.

Image

L'utilisateur peut remplacer le logo MJC apparaissant aux menus par l'illustration de son choix en remplaçant (ou créeant) le fichier SIGLEMJC.BMP dans le répertoire de l'application.

Format des étiquettes adresses

Page A4 21 x 29,7 comprenant 3 x 7 étiquettes

 | marge haute : 1,5 cm |
marge gauche 0,7 cm |  | marge droite 0,7 cm
 | marge basse : 1,5 cm |

PLUG-IN

Recherche et fonctionnement des plugins

Dans le module de recherche de adhérents, les développeurs peuvent inclure d’autres exécutables afin de produire des états libres personnalisés.

1 - Nom des PLUGIN

Les plugins sont des exécutables qui exploitent les données de la recherche pour des traitements complémentaires ; pour être reconnu par l’application, l’exécutable doit :

- être situé dans le répertoire de l’application

- porter l’extension EXE

- porter un nom commençant par PLUG (ex. PLUG1.EXE)

- être complété par un fichier en format txt, de même nom et d’extension TXT, situé dans le répertoire de l’application, et indiquant en une seule ligne l’explication du PLUGIN (ex : PLUG1.TXT)

2 - Fonctionnement

Lors de la sélection d’un PLUGIN, l’application MJC crée dans le répertoire de l’application un fichier séquentiel en mode texte SELECT.TMP qui indique :

- en ligne 1, le nombre de fiches

- à partir de la ligne 2 et sur chaque ligne, le numéro de chaque adhérent de la sélection

Ce fichier est recréé à chaque appel d’un plugin. Il peut donc être utile de prévoir

- de fermer le fichier SELECT.TMP dès qu’il n’est plus nécessaire d’en lire les données

- dans le développement du plugin de procéder à la suppression de ce fichier après traitement.


Installation en réseau

L’application supporte l’accès accès en réseau à la même base de données, par un nombre quelconque d’autres machines (y compris en réseau virtuel privé). Il faut alors procéder à l’installation sur chaque poste :

·installation ‘serveur de réseau’ : installe l’application complète, avec base de données et états. Cette installation est requise sur la machine qui sera choisie comme serveur, c’est-à-dire de préférence la machine la plus rapide de votre réseau, car elle devra partager sa puissance au service des terminaux.

·installation pour ‘terminal de réseau’ : n’installe que l’application, sans les bases de données (et rapports). Dès son premier lancement le programme vous demande de lui indiquer explicitement le chemin de la base de données sur le réseau.

(Si le chemin a été mal indiqué à l’installation, voir Problèmes techniques)


Réseau virtuel privé (VPN)

L'application étant aisément utilisable sur un réseau local, elle est exploitable aussi en réseau virtuel privé, par simple déclaration du chemin d'accès (Voir Paramètres généraux - Année courante ou Problèmes techniques)

Exemple d'installation d’un réseau virtuel privé OpenVpn avec

- un serveur

- un poste distant.

avec

- création d’un réseau virtuel privé en TCP

- utilisation du port 5000
- un serveur disposant d’une adresse IP fixe

- utilisation de OpenVpn.

- protection par une clé privée

- les adresses IP privées 10.3.0.1 affecté au serveur, et 10.3.0.2 au poste client.

1) sur chaque machine, télécharger le pack windows sur http://openvpn.net/index.php/download/community-downloads.html

2) Après installation, dans le menu Utilities, ajouter un interface TAP sur chaque machine (« Add a new Tap Virtual Ethernet Adapter »)

Par souci de clarté dans les interfaces réseaux, renommer ces deux connexions sous le nom « OpenVpn »

3) Sur le poste serveur, générer une clé de sécurité : (menu utilities « Generate a static open VPN Key »)

Cette clé est représentée par le fichier key.txt dans le sous répertoire {program files}/OpenVpn/config/key.txt

Elle doit être recopiée dans le répertoire équivalent du poste client.

4) Dans le même répertoire, sur le serveur ou le client,: les fichiers éventuels d’extension OVPN sont des exemples qui peuvent être supprimés

5) Sur le serveur, on recrée un fichier serveur.ovpn, dont le contenu est le suivant

#serveur.ovpn

proto tcp-server

dev tap

#Numéro du port TCP/UDP pour les deux hôtes (distant et local).

port 5000

#nom de la connexion (cf. panneau de configuration > Connexion reseau)

dev-node "openvpn"

#adresse ip de la machine dans le VPN

ifconfig 10.3.0.1 255.255.255.0

#active le mode de chiffrement statique par secret partagé

secret key.txt

persist-key

#Utiliser la compression dynamique LZO

comp-lzo

ping 10

push "ping 10"

#Régler le niveau de traces

verb 4

#Au bout de 10x la même ligne, plus de trace.

mute 10

route-method exe

route-delay 2

6) On peut alors lancer la connexion sur le serveur, dont on aura pris soin de noter l’adresse IP externe (par exemple 83.158.77.130). L'icône OpenVpn doit passer du rouge au jaune.

7) Sur le poste client, créer dans la configuration un fichier client.ovpn, avec le contenu suivant (modifier la ligne remote)

#client.ovpn

proto tcp-client

#adresse à laquelle le client doit se connecter

remote 83.158.77.130

dev tap

#nom de la connexion (cf. panneau de configuration > Connexion reseau)

dev-node "openvpn"

#adresse ip de la machine dans le VPN

ifconfig 10.3.0.2 255.255.255.0

#Numéro du port TCP/UDP pour les deux hôtes (distant et local).

port 5000

#active le mode de chiffrement statique par secret partagé

secret key.txt

persist-key

#Utiliser la compression dynamique LZO

comp-lzo

#Régler le niveau de traces

verb 4

#Au bout de 10x la même ligne, plus de trace.

mute 10

route-method exe

route-delay 2

(noe : si le serveur est en IP variable, il est possible lorsque le routeur le permet, d'utiliser un service de DNS dynamique comme http://www.no-ip.com/ : une fois obtenu un nom de domaine permettant de paramétrer le serveur, la ligne Remote prend simplmeent la forme de : Remote Nomdudomaine )

7) On peut alors lancer la connexion sur le client : normalement, les deux icônes sur chaque machine passent de l’étape jaune à l’étape verte.

Si ce n’est pas le cas, le problème vient certainement d’un firewall !

- sur les deux machines, s’assurer que les deux applications « openvpn » soient autorisées à traverser le pare-feu ;

- sur le routeur, contrôler que l’usage des ports TCP 5000 et 5001 est autorisé.

8) A cette étape, le serveur est accessible depuis le poste client sous le nom \\10.3.0.1\

9) Pour lancer automatiquement le VPN au démarrage des ordinateurs , il est plus simple d’inclure chaque lancement dans le groupe Démarrage de chaque machine, à savoir

- sur le serveur, un raccourci vers

"C:\Program Files (x86)\OpenVPN\bin\openvpn-gui-1.0.3.exe" --connect serveur.ovpn

(ou : "C:\Program Files\OpenVPN\bin\openvpn-gui-1.0.3.exe" --connect serveur.ovpn)

- sur le client

"C:\Program Files (x86)\OpenVPN\bin\openvpn-gui-1.0.3.exe" --connect client.ovpn

(ou : "C:\Program Files\OpenVPN\bin\openvpn-gui-1.0.3.exe" --connect client.ovpn)

En imaginant que sur le serveur, le répertoire contenant la base ait été partagée sous le simple nom de MJC, le chemin d'accès à la base de données depuis le poste client devient donc tout simplement : \\10.3.0.1\MJC


Réparation de la base

Ce module, accessible dans les paramètres de l'application (icône de réparation) permet de

- 'réparer' la base de données. En effet, certains problèmes intempestifs peuvent nuire à l'intégrité de votre base de données.

- 'compacter' la base de données.. La base de données a tendance à s'accroître systématiquement, de sorte qu'il est bon pour limiter son encombrement sur disque de la compacter de temps en temps.

Les modules par défaut (qui peuvent être désactivés par clic sur le carré rouge à cocher) sont

- Réparation des adhérents,
par contrôle des communes inexistantes : les communes inexistantes peuvent être soit supprimées des fiches adhérents (remplacées par le code 00000), soit ajoutées dans la table des communes
par contrôle des professions inexistantes, qui peuvent soit être détruites (remplacées dans les fiches adhérents par le code 000) soit ajoutées dans la table des professions (ajout du code)

- Réparation des activités, dont les codes inexistants donnent soit lieu à la suppression dans les fiches adhérents, soit à la création d'un code dans la table des activités (en tant qu'activité courante). Si des activités sont affectées à des adhérents inexistants, elles sont supprimées.

- Réparation des règlements, avec soit suppression des règlements dont le mode de paiement est inexistant, soit ajout du mode de règlement dans la table des modes.

Les traitements en cours donne lieu au passage en vert de la case correspondante, avec une transition éventuelle en orange pendant le recalcul des compteurs (nombre d'adhérents par activités, professions ou communes).


Structure de la base de données

Rappel : Les bases de données sont au format ACCESS 2. Les données sont directement accessibles par tout logiciel reconnaissant ce format (attention cependant à ne pas corrompre la base en la réenregistrant sous un nouveau format)

Table des activités par adhérents: Activadher

Nom | Type | Taille | Description
noadherent | Nombre (Réel double) |  | Numéro de l’adhérent
codeactivite | Texte | 5 | Code de l’activité
date | Date/Heure |  | Date du choix
frequence | Nombre (Réel double) |  | Fréquence 1 ou 0.5 (toutes semaines ou quinzaines)
passeencompta | Oui/Non |  | Ecriture passée en comptabilité
montant | Nombre (réel double) |  | Montant de l’activité

Index

iadherent | noadherent, Croissant
 | codeactivite, Croissant
icode | codeactivite, Croissant
idate | date, Croissant

Table des activités: Activités

Nom | Type | Taille | Description
code | Texte | 5 | Code de l’activité
libelle | Texte | 40 | Libellé de l’activité
nbadherents | Nombre (Réel double) |  | Nombre d’adhérents inscrits
nbmax | Nombre (Réel double) |  | Nombre d’iscrits maximum
montant | Nombre (Réel double) |  | Prix de l'activité (tarif 1)
animateur | Texte | 30 | Nom de l’animateur
jour1 | Nombre (Entier) |  | Jour 1 de l’activité (régulière)
heuredebut1 | Date/Heure |  | Heure 1 de début de l’activité (régulière)
heurefin1 | Date/Heure |  | Heure 1 de fin de l’activité (régulière)
jour2 | Nombre (Entier) |  | Jour 2 de l’activité (régulière)
heuredebut2 | Date/Heure |  | Heure 2 de début de l’activité (régulière)
heurefin2 | Date/Heure |  | Heure 2 de fin de l’activité (régulière)
jour3 | Nombre (Entier) |  | Jour 3 de l’activité (régulière)
heuredebut3 | Date/Heure |  | Heure 3 de début de l’activité (régulière)
heurefin3 | Date/Heure |  | Heure 3 de fin de l’activité (régulière)
jour4 | Nombre (Entier) |  | Jour 4 de l’activité (régulière)
heuredebut4 | Date/Heure |  | Heure 4 de début de l’activité (régulière)
heurefin4 | Date/Heure |  | Heure 4 de fin de l’activité (régulière)
jour5 | Nombre (Entier) |  | Jour 5 de l’activité (régulière)
heuredebut5 | Date/Heure |  | Heure 5 de début de l’activité (régulière)
heurefin5 | Date/Heure |  | Heure 5 de fin de l’activité (régulière)
lieu | Texte | 50 | Lieu de l’activité
type | Oui/Non |  | NON=activité régulière - OUI=autres types
libellecourt | Texte | 30 | Libellé court sur la carte d’adhérent
codecomptable4 | Texte | 9 | Code comptable compte client
codecomptable7 | Texte | 9 | Code comptable compte de vente
descriptif | Memo |  | Donne des indications complémentaires sur l’activité pour les stages, les centres de loisirs et les journées récréatives
montant2 | Nombre (Réel double) |  | Prix de l'activité (tarif 2)
montant3 | Nombre (Réel double) |  | Prix de l'activité (tarif 3)
codetva | Nombre (Réél double) |  | Code du taux de TVA applicable
montant4 | Nombre (Réel double) |  | Prix de l'activité (tarif 4)
montant5 | Nombre (Réel double) |  | Prix de l'activité (tarif 5)
montant6 | Nombre (Réel double) |  | Prix de l'activité (tarif 6)
montant7 | Nombre (Réel double) |  | Prix de l'activité (tarif 7)
montant8 | Nombre (Réel double) |  | Prix de l'activité (tarif 8)
montant9 | Nombre (Réel double) |  | Prix de l'activité (tarif 9)
montant10 | Nombre (Réel double) |  | Prix de l'activité (tarif 10)
nbmin | Nombre (Réel double) |  | Nombre d'inscrits minimum
description | Mémo |  | Description pour le catalogue html
arborescence | Nombre (Entier long) |  | Position dans l'arborescence du catalogue
ecatalogue | Nombre (Entier) |  |
codecomptablecentre | Texte | 8 | Code comptable analytique

Note : la zone descriptif contient diverses rubriques décrivant l’activité.

Pour un stage :

TYPE=S

DATEDÉBUT= date de début du stage

DATEFIN= date de fin du stage

NBJOURS= nombre de jour du stage

Pour un centre de loisirs :

TYPE=C

DATEDÉBUT= premier jour de la grille centre de loisirs

DATEFIN= dernier jour de la grille centre de loisirs

JOURDÉPART= premier jour de la semaine (de 0 à 6, pour lundi à dimanche)

JOURFIN= dernier jour de la semaine (de 0 à 6, pour lundi à dimanche)

NOTARIF= numéro du tarif (0 ou 1)

DÉTAIL= suite des jours concernés sous la forme jj/mm/aaaaMRA où MRA présents indiquent respectivement matin, repas et après-midi, et sont remplacés par des espaces s’ils ne sont pas sélectionnés.

PRIXREPAS= prix du repas

PRIXSEMAINE= prix pour une semaine complète

PRIXSEMAINER= prix pour une semaine complète avec repas

PRIXJOUR= prix pour un jour complet

PRIXMATIN= prix pour un matin

PRIXAM= prix pour une après-midi

Pour une journée récréative :

TYPE=J

DATEDÉBUT= premier jour de la grille journées récréatives

DATEFIN= dernier jour de la grille journées récréatives

JOURDÉPART= jour de la semaine (de 0 à 6, pour lundi à dimanche)

JOURFIN= dernier jour de la semaine (de 0 à 6, pour lundi à dimanche)

NOTARIF= numéro du tarif (0 ou 1)

DÉTAIL= suite des jours concernés sous la forme jj/mm/aaaaMRA où MRA présents indiquent respectivement matin, repas et après-midi, et sont remplacés par des espaces s’ils ne sont pas sélectionnés.

PRIXREPAS= prix du repas

PRIXJOUR= prix pour un jour complet

PRIXMATIN= prix pour un matin

PRIXAM= prix pour une après-midi

Index table

PrimaryKey | code, Croissant
Iarborescence | arborescence, croissant

Table des adhérents: Adhérents

Nom | Type | Taille | Description
noadherent | Nombre (Réel double) |  | Numéro d’adhérent
genre | Texte | 4 | Genre M. , Mme, Mlle, ou sans
nom | Texte | 30 | Nom
prénom | Texte | 20 | Prénom
rue1 | Texte | 50 | Première ligne de rue
rue2 | Texte | 50 | Seconde ligne de rue
codepostal | Texte | 5 | Code postal
telephone1 | Texte | 20 | Premier numéro de téléphone
telephone2 | Texte | 20 | Second numéro de téléphone
date de naissance | Date/Heure |  | Date de naissance
profession | Texte | 5 | Code profession
montantdu | Nombre (Réel double) |  | Montant restant du
nbactivités | Nombre (Réel double) |  | Nombre d’activités choisies
histo | Oui/Non |  | Créé pour l’année ou repris par historique
zonelibre1 | Texte | 40 | Texte de première zone libre
zonelibre2 | Texte | 40 | Texte de seconde zone libre
zonelibre3 | Texte | 40 | Texte de troisième zone libre
zonelibre4 | Texte | 40 | Texte de quatrième zone libre
zonelibre5 | Texte | 40 | Texte de cinquième zone libre
zonelibre6 | Texte | 40 | Texte de sixième zone libre
responsable | Texte | 40 | Nom du responsable légal
ville | Texte | 50 | Commune
url | Texte | 100 | url d'accès au catalogue internet
zonelibre7 | Texte | 40 | Texte de septième zone libre
zonelibre8 | Texte | 40 | Texte de huitième zone libre
zonelibre9 | Texte | 40 | Texte de neuvième zone libre

Index

codepostal | Codepostal, Croissant
 | Ville, croissant
nom | Nom, Croissant
nomprenom | Nom, Croissant
 | Prenom, Croissant
PrimaryKey | Noadherent, Croissant
profession | Profession, Croissant

Table des communes: Communes

Nom | Type | Taille | Description
codepostal | Texte | 5 | Code postal
ville | Texte | 50 | Ville
nb | Nombre (Réel double) |  | Nombre d’adhérents
éditer | Oui/Non |  | Booléen pour états imprimés
notarif | Entier |  | N° du tarif applicable
nb2 | Nombre (Réel double) |  | Nombre d’adhérents regroupé (statistiques)

Index

inb | nb, Croissant
iville | ville, Croissant
codepostal | codepostal, Croissant
 | ville, Croissant
inb2 | nb2, Croissant

Table des contrôles pour centres de loisirs: Datescl

Nom | Type | Taille | Description
codecentre | Nombre (Réel double) |  |
jour | Date/Heure |  | Jour concerné
matin | Nombre (Réel double) |  | Nombre d’adhérents le matin
repas | Nombre (Réel double) |  | Nombre d’adhérents au repas
am | Nombre (Réel double) |  | Nombre d’adhérents l’après-midi

Index

PrimaryKey | codecentre, Croissant
 | jour, Croissant

Table des contrôles pour journées récréatives: Datesjr

Nom | Type | Taille | Description
codecentre | Nombre (Réel double) |  |
jour | Date/Heure |  | Jour concerné
matin | Nombre (Réel double) |  | Nombre d’adhérents le matin
repas | Nombre (Réel double) |  | Nombre d’adhérents au repas
am | Nombre (Réel double) |  | Nombre d’adhérents l’après-midi

Index

PrimaryKey | codecentre, Croissant
 | jour, Croissant

Table des modes de règlement: Moderegl

Nom | Type | Taille | Description
noreglement | Nombre (Réel double) |  | Code règlement
libellé | Texte | 30 | Libellé du règlement
resumé | Texte | 20 | Résumé du libellé
codecomptable | Texte | 9 | Code comptable (512,514, 531, etc...)

Index

PrimaryKey

noreglement, Croissant

Table des paramètres généraux: Paramètres

Nom | Type | Taille | Description
genre | Texte | 4 | Genre le plus courant (M., Mlle, Mme, ...)
dernoadherent | Nombre (Réel double) |  | Prochain numéro d’adhérent
fintranche1 | Nombre (Réel double) |  | Age de fin de la tranche 1 statistiques de répartition
fintranche2 | Nombre (Réel double) |  | Age de fin de la tranche 2 statistiques de répartition
fintranche3 | Nombre (Réel double) |  | Age de fin de la tranche 3 statistiques de répartition
fintranche4 | Nombre (Réel double) |  | Age de fin de la tranche 4 statistiques de répartition
fintranche5 | Nombre (Réel double) |  | Age de fin de la tranche 5 statistiques de répartition
fintranche6 | Nombre (Réel double) |  | Age de fin de la tranche 6 statistiques de répartition
fintranche7 | Nombre (Réel double) |  | Age de fin de la tranche 7 statistiques de répartition
fintranche8 | Nombre (Réel double) |  | Age de fin de la tranche 8 statistiques de répartition
fintranche9 | Nombre (Réel double) |  | Age de fin de la tranche 9 statistiques de répartition
fintranche10 | Nombre (Réel double) |  | Age de fin de la tranche 10 statistiques de répartition
nbadherentsf | Nombre (Réel double) |  | Nombre d’adhérents femmes
nbadherentsh | Nombre (Réel double) |  | Nombre d’adhérents hommes
motdepasse | Texte | 20 | Mot de passe général
motdepasseparam | Texte | 20 | Mot de passe pour accès aux paramètres
motdepassecatalogue | Texte | 20 | Mot de passe pour accès aux paramètres catalogue
nbadherentss | Nombre (Réel double) |  | Nombre d’adhérents sans genre
datedepart | Date/Heure |  | Utile aux rapport imprimés
datefin | Date/Heure |  | Utile aux rapport imprimés
afintranche1 | Nombre (Réel double) |  | Age de fin de la tranche 1 adhésion automatique
afintranche2 | Nombre (Réel double) |  | Age de fin de la tranche 2 adhésion automatique
afintranche3 | Nombre (Réel double) |  | Age de fin de la tranche 3 adhésion automatique
afintranche4 | Nombre (Réel double) |  | Age de fin de la tranche 4 adhésion automatique
afintranche5 | Nombre (Réel double) |  | Age de fin de la tranche 5 adhésion automatique
afintranche6 | Nombre (Réel double) |  | Age de fin de la tranche 6 adhésion automatique
afintranche7 | Nombre (Réel double) |  | Age de fin de la tranche 7 adhésion automatique
afintranche8 | Nombre (Réel double) |  | Age de fin de la tranche 8 adhésion automatique
afintranche9 | Nombre (Réel double) |  | Age de fin de la tranche 9 adhésion automatique
afintranche10 | Nombre (Réel double) |  | Age de fin de la tranche 10 adhésion automatique
adhésion1 | Texte | 5 | Code de l’adhésion automatique tranche 1
adhésion2 | Texte | 5 | Code de l’adhésion automatique tranche 2
adhésion3 | Texte | 5 | Code de l’adhésion automatique tranche 3
adhésion4 | Texte | 5 | Code de l’adhésion automatique tranche 4
adhésion5 | Texte | 5 | Code de l’adhésion automatique tranche 5
adhésion6 | Texte | 5 | Code de l’adhésion automatique tranche 6
adhésion7 | Texte | 5 | Code de l’adhésion automatique tranche 7
adhésion8 | Texte | 5 | Code de l’adhésion automatique tranche 8
adhésion9 | Texte | 5 | Code de l’adhésion automatique tranche 9
adhésion10 | Texte | 5 | Code de l’adhésion automatique tranche 10
adhésion11 | Texte | 5 | Code de l’adhésion automatique tranche 11
texteannee | Texte | 20 | Texte de la carte d’adhérent
dernoreglement | Nombre (Réel double) |  | Dernier code règlement
cournoreglement | Nombre (Réel double) |  | Code de règlement par défaut
nbhisto | Nombre (Réel double) |  | Nombre de rappels d’historique
journalvente | Texte | 6 | Nom du journal de vente SYBEL
journalbanque | Texte | 6 | Nom du journal de vente SYBEL
fichiersybel | Texte | 100 | Nom du fichier d’exportation SYBEL
centre | Texte | 20 | Nom du centre analytique SYBEL
datedergener | Date/Heure |  | Date de dernière génération comptable
interfacecomptable | Oui/Non |  | Interface comptable actif ou non
journalcaisse | Texte | 6 | Nom du journal de caisse SYBEL
libelzonelibre1 | Texte | 20 | Libellé de première zone libre
libelzonelibre2 | Texte | 20 | Libellé de seconde zone libre
libelzonelibre3 | Texte | 20 | Libellé de troisième zone libre
libelzonelibre4 | Texte | 20 | Libellé de quatrième zone libre
libelzonelibre5 | Texte | 20 | Libellé de cinquième zone libre
libelzonelibre6 | Texte | 20 | Libellé de sixième zone libre
impressionfacture | Oui/Non |  | Impression des factures proposée
numerofacture | Nombre (Réel double) |  | Dernier numéro de facture
formatfacture | Texte | 12 | Format de la facture
nom | Texte | 40 | Coordonnées : nom
rue1 | Texte | 40 | Coordonnées : première ligne de rue
rue2 | Texte | 40 | Coordonnées : seconde ligne de rue
codepostal | Texte | 5 | Coordonnées : code postal
ville | Texte | 40 | Coordonnées : ville
telephone | Texte | 20 | Coordonnées : téléphone
telecopie | Texte | 20 | Coordonnées : télécopie
typecomptabilite | Nombre (Réel double) |  | Type de comptabilité (SYBEL, CIEL, EBP, SAGE ou QUADRA)
journalbanqueciel | Texte | 2 | Journal de banque CIEL
journalcaisseciel | Texte | 2 | Journal de caisse CIEL
journalventeciel | Texte | 2 | Journal de vente CIEL
centreciel | Texte | 6 | Centre analytique CIEL
fichierciel | Texte | 100 | Fichier d’exportation CIEL
datedebutcl | Date/Heure |  | Date de début du prochain centre de loisirs
datefincl | Date/Heure |  | Date de fin du prochain centre de loisirs
maxcl | Oui/Non |  | Contrôle des limites centres de loisirs
maxmatincl | Nombre (Réel double) |  | Maximum d’adhérents matin centres de loisirs
maxrepascl | Nombre (Réel double) |  | Maximum d’adhérents repas centres de loisirs
maxamcl | Nombre (Réel double) |  | Maximum d’adhérents après-midi centres de loisirs
jourdebutcl | Nombre (Entier) |  | Jour de la semaine de début centres de loisirs
jourfincl | Nombre (Entier) |  | Jour de la semaine de fin centres de loisirs
Datedebutjr | Date/Heure |  | Date de début de prochaine journée récréative
Datefinjr | Date/Heure |  | Date de fin de prochaine journée récréative
Maxjr | Oui/Non |  | Contrôle des limites journées récréatives
maxmatinjr | Nombre (Réel double) |  | Maximum d’adhérents matin journées récréatives
maxrepasjr | Nombre (Réel double) |  | Maximum d’adhérents repas journées récréatives
maxamjr | Nombre (Réel double) |  | Maximum d’adhérents après-midi journées récréatives
jourjr | Nombre (Entier) |  | Jour de la semaine journées récréatives
boutonson | Oui/Non |  | Bouton sonore (obsolète)
nomduboutonson | Texte | 50 | Nom du fichier son du bouton sonore (obsolète)
erreurson | Oui/Non |  | Son spécial sur erreur (obsolète)
nomdusonerreur | Texte | 50 | Nom du fichier son du son spécial sur erreur (obsolète)
an2000 | Oui/Non |  | Gestion spécifique de l’an 2000
numerodeversion | Texte | 10 | Numéro de version de la base de données
controlehistorique | Oui/Non |  | Historique recherché automatiquement à la saisie
libre | Texte | 50 | Utilisé pour certains états
responsable | Texte | 30 | Nom du responsable de la MJC
fonction | Texte | 30 | Fonction du responsable (directeur, ...)
unitexport | Texte | 50 | Unité de destination des exportations
datederexport | Date |  | Date de dernière exportation des adhérents
gestionutilisateur | Oui/non |  | Mode gestion des utilisateurs activé ou non
textefacture | Texte | 50 | Texte précédent le nom de l’utilisateur sur la facture
tauxtva0 | Nombre (Réel double) |  | Taux de TVA pour le code TVA 0
tauxtva1 | Nombre (Réel double) |  | Taux de TVA pour le code TVA 1
tauxtva2 | Nombre (Réel double) |  | Taux de TVA pour le code TVA 2
tauxtva3 | Nombre (Réel double) |  | Taux de TVA pour le code TVA 3
libeltva0 | Texte | 20 | Libellé pour le code TVA 0
libeltva1 | Texte | 20 | Libellé pour le code TVA 1
libeltva2 | Texte | 20 | Libellé pour le code TVA 2
libeltva3 | Texte | 20 | Libellé pour le code TVA 3
comptetva0 | Texte | 9 | Code comptable pour code TVA 0
comptetva1 | Texte | 9 | Code comptable pour code TVA 1
comptetva2 | Texte | 9 | Code comptable pour code TVA 2
comptetva3 | Texte | 9 | Code comptable pour code TVA 3
entetefacture | Texte | 8 | Texte d’entête facture (facture, reçu…)
journalventeebp | Texte | 8 | Journal de banque EBP
journalcaisseebp | Texte | 8 | Journal de caisse EBP
centreebp | Texte | 8 | Centre analytique EBP
fichierebp | Texte | 100 | Fichier d'exportation EBP
monnaiecourante | Oui/Non |  | Non=francs ; Oui=euros
doublemonnaie | Oui/Non |  | Gestion en double monnaie
eurosymbole | Texte | 2 | Symbole de l’euro
francsymbole | Texte | 2 | Symbole du franc
zonelibremail | Texte | 6 | Indique en position 1 à 6 pour les zones libres 1 à 6 respectivement un caractère de valeur sommée de 1 - si l'envoi d'email est autorisé avec la zone comme adresse 2 - si la zone doit être reprise en historique 4 - si la zone doit être reprise en fiche famille 8 - si l'envoi de SMS est autorisé avec la zone comme adresse
journalbanquesage | Texte | 8 | Journal de banque SAGE
journalventesage | Texte | 8 | Journal de vente SAGE
journalcaissesage | Texte | 8 | Journal de caisse SAGE
centresage | Texte | 8 | Centre analytique SAGE
fichiersage | Texte | 100 | Fichier d'exportation SAGE
libellesage | Texte | 30 | Libellé d'exportation SAGE
journalbanquequadra | Texte | 2 | Journal de banque QUADRA
journalventequadra | Texte | 2 | Journal de vente QUADRA
journalcaissequadra | Texte | 2 | Journal de caisse QUADRA
fichierquadra | Texte | 100 | Fichier d'exportation QUADRA
rappeldernierutilisateur | Oui/Non |  | Oui = rappel automatique du dernier utilisateur au prochain lancement
dernierutilisateur | Texte | 40 |
forcagecompteur | Oui/Non |  | Dépassement autorisé du nombre d'inscrits max.
motpassecompteur | Texte | 20 | Mot de passe pour dépasser le nombre d'inscrits max.
dernoarborescence | Numérique (entier long) |  | Dernier numéro de l'arborescence du catalogue
ficheactivite | Mémo |  | Structure de la fiche activité du catalogue
fichecompteur | Mémo |  | Structure de la fiche compteur du catalogue
ficheadherent | Mémo |  | Structure de la fiche adhérent du catalogue
fichestage | Mémo |  | Structure de la fiche stage du catalogue
fichecentre | Mémo |  | Structure de la fiche centre de loisirs du catalogue
fichejournee | Mémo |  | Structure de la fiche journée récréative du catalogue
adhetiq | Oui/Non |  | Indique si les codes adhésions sont imprimés ou non sur les étiquettes
libelzonelibre7 | Texte | 20 | Libellé de septième zone libre
libelzonelibre8 | Texte | 20 | Libellé de huitième zone libre
libelzonelibre9 | Texte | 20 | Libellé de neuvième zone libre
textesaison | Texte | 20 | Texte année (saison) notamment sur les factures

Table des profession: Professions

Nom | Type | Taille | Description
code | Texte | 5 | Code profession
libelle | Texte | 50 | Libellé de la profession
nb | Nombre (Réel double) |  | Nombre d’adhérents concernés

Index

alibelle | Libelle, Croissant
inb | Nb, Decroissant
PrimaryKey | Code, Croissant

Table des règlements: Règlements

Nom | Type | Taille | Description
noadherent | Nombre (Réel double) |  | Numéro d’adhérent
date | Date/Heure |  | Date du règlement
libelle | Texte | 50 | Libellé du règlement
montant | Nombre (Réel double) |  | Montant réglé
type | Nombre (Réel double) |  | Code du mode de règlement
passeencompta | Oui/Non |  | Ecriture généré ou non en comptabilité
code4 | Texte | 9 | Code spécial du compte client
codecentre | Texte | 8 | Code comptable analytique

Index

idate | date, Croissant
noadherent | noadherent, Croissant
 | date, Croissant
type | type, Croissant

Table des tarifs centres de loisir et journées récréatives : Tarifs

Nom | Type | Taille | Description
tarifsemaine | Texte | 70 | Tarifs semaine des centres de loisir (10 x 7 caractères)
tarijour | Texte | 70 | Tarifs jour des centres de loisir (10 x 7 caractères)
tarifmatin | Texte | 70 | Tarifs matin des centres de loisir (10 x 7 caractères)
tarifam | Texte | 70 | Tarifs après-midi des centres de loisir (10 x 7 caractères)
tarifrepas | Texte | 70 | Tarifs repas des centres de loisir (10 x 7 caractères)
tarifsemainer | Texte | 70 | Tarifs semaine des journées récréatives (10 x 7 caractères)
tarijourr | Texte | 70 | Tarifs jour des journées récréatives (10 x 7 caractères)
tarifmatinr | Texte | 70 | Tarifs matin des journées récréatives (10 x 7 caractères)
tarifamr | Texte | 70 | Tarifs après-midi des journées récréatives (10 x 7 caractères)
tarifrepasr | Texte | 70 | Tarifs repas des journées récréatives (10 x 7 caractères)
Nomtarifjr | Texte | 150 | Nom des tarifs journées récréatives (10 x 15 caractères)
Tarif | Texte | 150 | Nom des tarifs centres de loisir (10 x 15 caractères)
codecentre | Nombre (Réel double) |  | Code interne du tarif
libellecentre | Texte | 50 | Libelle du centre de loisir ou de la journée récréative
debutCL | Texte | 3 | Code de départ des codes CL du centre automatique
finCL | Texte | 3 | Code de fin des codes CL du centre automatique
debutJR | Texte | 3 | Code de départ des codes JR de journée automatique
finJR | Texte | 3 | Code de fin des codes JR de journée automatique

Table des utilisateurs: Utilisateurs

Nom | Type | Taille | Description
nom | Texte | 40 | Nom d’utilisateur

Index

primarykey

nom, Croissant

Table des messages: Messages

Nom | Type | Taille | Description
resume | Texte | 20 | Référence du message
texte | Mémo |  | Corps du message
type | Texte | 1 | M=mail ; S=SMS A=fiche Html catalogue Activité C=fiche Html catalogue Centre de loisirs J=fiche Html catalogue Journée récréative D=fiche Html catalogue Adhérent E=fiche Html catalogue Compteur
sujet | Mémo |  | Sujet du mail

Index

primarykey

resume, Croissant

Table de l'arborescence du catalogue: Arborescence

Nom | Type | Taille | Description
libellé | Mémo |  | Libellé de l'arborescence
dependance | Entier long |  | Dépendance de la branche supérieure
noarborescence | Entier long |  | Numéro de l'arboresence
ordre | Entier long |  | Ordre dans le niveau
nbarticles | Entier long |  | Nombre d'activités dans la branche
editer | Oui/Non |  | Editer ou non dans la catalogue

Index

primarykey | noarborescence, Croissant
 | ordre, croissant
idependance | dependance, croissant


Catalogue internet

Le catalogue internet apporte les possibilités suivantes :
- générer un site internet local,
- incluant les fiches activités et leur catalogue structuré, et indiquant le nombre de places restant disponibles

- les fiches adhérents, accessibles directement ou par QRcode

et

- le transfert automatique de ce site vers un site distant FTP.

Il s'appuie sur :

- des formats de fiches adhérent, activités et compteur définis par l'utilisateur, à l'aide éventuellement de l'éditeur HTML inclus ;

- une classification structurée des activités, indiquant les rubriques à éditer ;

- un générateur intégré de QRCode, y compris sur étiquettes (imprimante étiqueteuse),

- un module dédié à assurer le transfert FTP de toutes les données, y compris générées par d'autres machines du réseau.

La définition des formats de fiches, ainsi que le paramétrage des envois FTP nécessite des compétences techniques.

La catalogue internet :
- génère automatiquement des fiches (activités, adhérents, compteurs, catalogue), sur une site local (situé au même emplacement que la base de données partagées, dans un sous-répertoire \site, structurée selon les paramètres généraux).
- assure éventuellement le transfert automatique de ce site internet local vers un site internet distant par transfert FTP.

Paramètres généraux

- URL générale d'accès au catalogue : permet de tester rapidement le bon fonctionnement du catalogue. Cette adresse peut être locale ou http://.

- Création/Transfert automatique des fiches activités : toute modification d'une fiche activité donne lieu à la régénération de la fiche locale correspondante, selon le format défini pour les fiches activités.

- Création/Transfert automatique des compteurs d'activités : toute modification d'une fiche activité, ou toute inscription (ou annulation d'inscription) donne lieu à la régénération de la fiche compteur de places disponibles locale correspondante, selon le format défini pour les fiches compteurs.

- Création/Transfert automatique des fiches adhérents : toute modification d'une fiche adhérent donne lieu à la régénération de la fiche locale correspondante, selon le format défini pour les fiches adhérents.

Les noms de fiches peuvent être précédés ou nom d'un préfixe : par exemple, le préfixe ACT génère des fichiers ACTADH01.html pour l'activité ADH01, ACTADH02.htm, etc...

Si les répertoires des fiches compteurs et activités est similaire, il faut impérativement indiquer un préfixe pour différencier les deux types de fiches.

La fiche compteur est liberté apportée pour indiquer le nombre de places restant disponibles : cette information peut en effet soit figurer dans la fiche activité (qui sera systématiquement générée lors de toute modification), soit dans une fiche spécifique n'ayant que pour fonction de gérer ce compteur, et que l'utilisateur pourra insérer selon ses choix dans toute autre page Html (y compris donc dans la fiche activité sous forme de <Iframe>).

Le choix des champs à inclure dans chaque fiche peut se faire soit à l'aide de la liste déroulante spécifique de l'éditeur, soit être directement saisi en respectant les syntaxes de champs indiquées ci-dessous.

La fiche adhérent peut être précédée d'un préfixe (par exemple ADHERENT générera des fiches ADHERENT00001 pour l'adhérent 00001, etc...) ou utiliser un identifiant codé : cet identifiant unique pour chaque adhérent est une clé de 20 caractères générée aléatoirement (combinaison de a à z et 0 à 9) : en effet, une fiche adhérent non codée mise en ligne donnerait aisément accès aux informations privées de chaque adhérent (puisqu'il suffirait de constituer l'url d'accès par le préfixe suivi d'un numéro quelconque d'adhérent). En codant l'information, la fiche n'est accessible qu'à l'adhérent informé de l'url par email (voir cette fonction en saisie ou consultation), ou à l'aide du QRCode (qui peut être imprimé sur l'étiquette des imprimantes étiqueteuses).

Fiche activités

Les fiches activités servent à la génération des fiches de chaque activité, mais aussi du catalogue général.

Il est donc utile de définir une arborescence structurée du catalogue, en classant par rubriques les activités proposées, et en indiquant quelles branches doivent être présentées dans le catalogue. Il est ainsi possible de gérer une rubrique à ne pas éditer, pour y regrouper les activités ne devant pas figurer dans le catalogue.

Gestion de l'arborescence :

Une rubrique peut être ajoutée, supprimée ou renommée.
L'ajout d'une rubrique crée une sous-rubrique sous la rubrique sélectionnée.
La suppression d'une rubrique entraîne la suppression de tous les sous-rubriques et des indications d'activités qu'elle contient. Si la rubrique n'est donc pas vide, confirmation sera demandée.
Une rubrique peut porter un nom quelconque. Si la rubrique contient des activités, son nom est immédiatement suivi du nombre des activités qu'elle contient (entre crochets).

Une rubrique peut être déplacée :
- dans l'arborescence par simple glisser-déplacer, avec lâché du bouton de la souris sur la nouvelle rubrique d'intégration. Toutes les sous-rubriques et activités sont déplacées avec la rubrique.
- par les boutons [image] ou [image].

L'arborescence est développée ou réduite :
- par clic sur les boutons + et - de chaque dossier
- par les boutons de commande 'Tout développer' ou 'Tout réduire'

Le déplacement d'une activité vers un dossier se fait par simple glisser-déplacer de la fenêtre de droite vers un dossier de la fenêtre de gauche. Cette affectation d'une activité à une rubrique peut aussi se faire sur la fiche activité.

Les fiches :

Le contenu de chaque fiche activité, adhérent ou compteur, est librement définie par le concepteur du site. Il dispose à cet effet d'un éditeur HTML sommaire, qui permet de travailler soit en mode visuel (wysiwyg), soit directement en HTML, permettant ainsi l'insertion de toutes formes de scripts html spéciaux (voir l'exemple de la fiche compteur), ou de coller toute autre description HTML issue d'éditeur plus complet.
L'éditeur inclut aussi les fonctions de langages suivantes :
- [[%IF_condition_THEN%]] ... [[%ELSE%]] ... [[%ENDIF%]], afin de générer des présentations conditionnelles (avec les opérateurs conditionnels =, <>, > et <).
Exemple dans la fiche activité par défaut :
[[%IF_[[Nombre_de_places_disponibles]]=0_THEN%]]Groupe complet[[%ELSE%]][[Iframe_compteur height="45" frameborder="0" scrolling="no" width="300"]][[%ENDIF%]]
Affiche Groupe complet si le nombre aucun place n'est plus disponible pour l'activité, ou insère le compteur de places disponibles sinon.
Exemple dans la fiche compteur par défaut, pour la gestion des pluriels :

place[[%IF_[[Nombre_de_places_disponibles]]>0_THEN%]]s[[%ENDIF%]] disponible[[%IF_[[Nombre_de_places_disponibles]]>0_THEN%]]s[[%ENDIF%]]
Les balises peuvent encadrer du code html complexe afin de générer des fiches spécifiques à certains critères.

- [[%FORMAT(variable,format)%]] pour formater la variable correspondante de la fiche.
Exemple dans la fiche activités par défaut : [[%FORMAT([[Heure_début1]],"hh:mm")%]] qui n'affiche que les heures et minutes

La fonction format permet ainsi de présenter des chaînes de caractères, des nombres ou des dates, dans des formats définis par l'utilisateur.

·Fiches activité

Champs simples :

[[Code_activité]] | [[Libellé_de_l'activité]] |
[[Animateur]] | [[Lieu]] | [[Description]]
[[Jour_1]] | [[Heure_début1]] | [[Heure_fin1]]
[[Jour_2]] | [[Heure_début2]] | [[Heure_fin2]]
[[Jour_3]] | [[Heure_début3]] | [[Heure_fin3]]
[[Jour_4]] | [[Heure_début4]] | [[Heure_fin4]]
[[Jour_5]] | [[Heure_début5]] | [[Heure_fin5]]
[[Nombre_d'inscrits]] | [[Nombre_maximum]] (d'inscrits) | [[Nombre_minimum]] (d'inscrits)
[[Nombre_de_places_disponibles]] |  |
[[Prix_tarif1]] | [[Prix_tarif2]] | [[Prix_tarif3]]
[[Prix_tarif4]] | [[Prix_tarif5]] | [[Prix_tarif6]]
[[Prix_tarif7]] | [[Prix_tarif8]] | [[Prix_tarif9]]
[[Prix_tarif10]] |  |

Champs complexes :

[[Iframe_compteur]] | : insère en Iframe la fiche compteur
[[arborescence]] | : insère les liens vers l'arborescence fiche catalogue
[[QRCode]] | : insère l'image BMP du QRCode représentant lien internet de la fiche activité (taille 150 pixels par défaut, si nom précisé par la syntaxe [[QRCode taille]]

·Fiche centre de loisirs

Champs simples :

[[Code_activité]] | [[Libellé_de_l'activité]] |
[[Animateur]] | [[Lieu]] | [[Description]]
[[Date_de_début]] | [[Date_de_fin]] |
[[Nombre_d'inscrits]] | [[Nombre_maximum]] (d'inscrits) | [[Nombre_minimum]] (d'inscrits)
[[Nombre_de_places_disponibles]] |  |
[[Prix_tarif1]] | [[Prix_tarif2]] | [[Prix_tarif3]]
[[Prix_tarif4]] | [[Prix_tarif5]] | [[Prix_tarif6]]
[[Prix_tarif7]] | [[Prix_tarif8]] | [[Prix_tarif9]]
[[Prix_tarif10]] |  |

Champs complexes :

[[Iframe_compteur]] | : insère en Iframe la fiche compteur
[[arborescence]] | : insère les liens vers l'arborescence fiche catalogue
[[QRCode]] | : insère l'image BMP du QRCode représentant lien internet de la fiche centre de loisirs (taille 150 pixels par défaut, si nom précisé par la syntaxe [[QRCode taille]]

·Fiche Journée récréative

Champs simples :

[[Code_activité]] | [[Libellé_de_l'activité]] |
[[Animateur]] | [[Lieu]] | [[Description]]
[[Date_de_début]] | [[Date_de_fin]] |
[[Nombre_d'inscrits]] | [[Nombre_maximum]] (d'inscrits) | [[Nombre_minimum]] (d'inscrits)
[[Nombre_de_places_disponibles]] |  |
[[Prix_tarif1]] | [[Prix_tarif2]] | [[Prix_tarif3]]
[[Prix_tarif4]] | [[Prix_tarif5]] | [[Prix_tarif6]]
[[Prix_tarif7]] | [[Prix_tarif8]] | [[Prix_tarif9]]
[[Prix_tarif10]] |  |

Champs complexes :

[[Iframe_compteur]] | : insère en Iframe la fiche compteur
[[arborescence]] | : insère les liens vers l'arborescence fiche catalogue
[[QRCode]] | : insère l'image BMP du QRCode représentant lien internet de la fiche journée récréative (taille 150 pixels par défaut, si nom précisé par la syntaxe [[QRCode taille]]

·Fiche Stage

Champs simples :

[[Code_activité]] | [[Libellé_de_l'activité]] |
[[Animateur]] | [[Lieu]] | [[Description]]
[[Date_de_début]] | [[Date_de_fin]] |
[[Nombre_d'inscrits]] | [[Nombre_maximum (d'inscrits)]] | [[Nombre_minimum]] (d'inscrits)
[[Nombre_de_places_disponibles]] |  |
[[Prix_tarif1]] | [[Prix_tarif2]] | [[Prix_tarif3]]
[[Prix_tarif4]] | [[Prix_tarif5]] | [[Prix_tarif6]]
[[Prix_tarif7]] | [[Prix_tarif8]] | [[Prix_tarif9]]
[[Prix_tarif10]] |  |

Champs complexes :

[[Iframe_compteur]] | : insère en Iframe la fiche compteur
[[arborescence]] | : insère les liens vers l'arborescence fiche catalogue
[[QRCode]] | : insère l'image BMP du QRCode représentant lien internet de la fiche stage (taille 150 pixels par défaut, si nom précisé par la syntaxe [[QRCode taille]]

Fiches de Compteur d'activité

Champs simples :

[[Code_activité]] | [[Libellé_de_l'activité]] |
[[Nombre_d'inscrits]] | [[Nombre_maximum]] (d'inscrits) | [[Nombre_minimum]] (d'inscrits)
[[Nombre_de_places_disponibles]] |  |

Par défaut la fiche compteur initiale présente l'utilisation d'un compteur de type graphique (utilisation d'un sous répertoire /digits contenant les images des dix chiffres utilisés en format GIF). Ce script peut être conservé, adapté en fonction des besoins de l'utilisateur (pour revenir au script d'origine, comme dans pour toutes les autres fiches, il suffit dans l'éditeur, en mode HTML, de détruire toutes les données saisies, puis de valider la fiche : en rappelant la fiche, désormais entièrement vide, l'application reprend la fiche d'exemple contenant le script. Les données du script originel sont automatiquement transmises vers le site FTP.)

Fiche adhérent

Champs simples :

[[No_adhérent]] |  |
[[Genre]] | [[Nom]] | [[Prénom]]
[[Rue1]] | [[Rue2]] |
[[Code_postal]] | [[Ville]] |
[[Téléphone_1]] | [[Téléphone_2]] |
[[Montant_restant_du]] | [[Date_de_naissance]] |
[[Libellé_zone_libre_1]] | [[Zone_libre_1]] |
[[Libellé_zone_libre_2]] | [[Zone_libre_2]] |
[[Libellé_zone_libre_3]] | [[Zone_libre_3]] |
[[Libellé_zone_libre_4]] | [[Zone_libre_4]] |
[[Libellé_zone_libre_5]] | [[Zone_libre_5]] |
[[Libellé_zone_libre_6]] | [[Zone_libre_6]] |
[[Code_activité1]] | [[Code_activité2]] | [[Code_activité3]]
[[Code_activité4]] | [[Code_activité5]] | [[Code_activité6]]

Champs complexes : insère les codes activités avec liens vers les fiches activités

[[Lien_code_activité1]] | [[Lien_code_activité2]] | [[Lien_code_activité3]]
[[Lien_code_activité4]] | [[Lien_code_activité5]] | [[Lien_code_activité6]]

[[QRCode]]

: insère l'image BMP du QRCode représentant lien internet de la fiche adhérent (taille 150 pixels par défaut, si nom précisé par la syntaxe [[QRCode taille]]

Régénération du site

La régénération du site recrée automatiquement toutes les fiches définies en paramètres du catalogue (activités et catalogue, adhérents, compteurs) et assure éventuellement leur transfert FTP.

Note : pour des bases de données, le volume de données internet généré peut s'avérer très conséquent. Le module d'envoi FTP de l'application, assurant le transfert en arrière plan des documents, peut s'avérer inadapté en terme vitesse de transfert, puisqu'il assure l'envoi selon le timing régulier défini par l'utilisateur dans la configuration : destiné à assurer la mise à jour courante, ce module peut, pour le transfert de milliers de documents, nécessiter plusieurs heures d'exécution, et il peut alors être préférable d'utiliser un client FTP dédié (CuteFtp, Totalcommander, etc...). Mieux vaut alors dans ce cas désactiver temporairement toutes les fonctions d'envoi dans les paramètres FTP, pour ne générer qu'un site local.


Configuration FTP

- Activer/désactiver les fonctions d'envoi FTP : détermine si le module intégré d'envoi en FTP doit être activé, pour envoyer directement sur le serveur FTP les documents HTML (fiches adhérents, activités, compteurs, catalogue) créés ou modifiés, selon un timing d'envoi défini en 10ème de secondes. Si fonctions d'envoi sont désactivées et que les paramètres de génération du catalogue internet sont renseignés, seul le site local est généré, sans transfert automatique.

- Simuler l'envoi FTP sur le serveur : cette fonction permet d'organiser l'envoi des fichiers FTP depuis certaines machines seulement. Si la simulation est active, les documents à éventuellement envoyer ne sont pas directement transmis par la machine, mais notés comme à transférer, et sont alors envoyés par les machines du réseau où est activée la

- Simulation FTP : lorsque cette option est activée, tout comme le transfert FTP, le poste surveille, selon le délai indiqué, les documents créés ou modifiés par les autres postes en mode simulation, et en assure le transfert vers le site FTP. Ce système permet ainsi de consacrer un seul poste du réseau à l'envoi des fichiers, sans ainsi ralentir les autres postes. Il est même envisageable de dédier ainsi un poste peu utilisé à cette seule opération de mise en ligne.

- Les paramètres standard du FTP (hôte, utilisateur, mot de passe, port, répertoire distant et mode passif ou actif) sont à renseigner pour le bon fonctionnement du transfert FTP. Ces paramètres peuvent être sauvegardés dans le répertoire courant de la base de données, et ainsi rechargés automatiquement sur n'importe quel autre poste.


Licence

Licence d'utilisation

 Accueil Précédent

Conditions générales d’utilisation

·Objet: ADAGIO accorde au Client qui accepte en qualité de licencié, un droit personnel, non transférable et non exclusif, d'utilisation du progiciel selon les seules spécifications décrites dans la documentation du progiciel. Le progiciel reste la propriété exclusive et absolue d'ADAGIO qui demeure seul dépositaire, au regard du Client, des codes sources.

·Utilisation du progiciel: le progiciel sous licence ne peut être utilisé que sur un seul site, sauf dérogation et autorisation expresse donnée par écrit par ADAGIO. La mise en oeuvre et l'installation du progiciel sont faîtes par le Client et sous sa responsabilité et son contrôle.

·Enregistrement de la licence et confidentialité : la licence est matérialisée, après règlement, par la seule fourniture avec la facture correspondante d'un nom d'utilisateur et d'un mot de passe permettant l'usage complet de l'application et l'accès aux mises à jour. Le client s'engage à ne pas communiquer ni céder à autrui, à titre onéreux ou gratuit, son nom d'utilisateur et son mot de passe ; en cas d'abus, outre les éventuelles conséquences pénales, le client verra ses données d'accès aux serveurs supprimées.

·Reproduction - propriété du logiciel: le progiciel et sa documentation sont protégés par les articles L. 122-6 et L. 335-3 du Code de la Propriété Intellectuelle. Le Client s'engage à ne pas porter atteinte, directement ou indirectement au droit de propriété absolu d'ADAGIO sur le progiciel.

·Responsabilité: ADAGIO est tenu d'une simple obligation de moyen. ADAGIO ne saurait être tenu responsable, de quelque façon que ce soit, d'un quelconque préjudice subi par le Client, causé directement ou indirectement par l'utilisation du progiciel.

·Garantie: ADAGIO garantit pendant un délai de trois mois à compter de la date d'acquisition du progiciel, toutes anomalies, incidents, erreurs ou défaut de fonctionnement, à condition qu' il n'y ait pas eu de modifications apportées au logiciel par le Client ou toute autre personne non habilitée par ADAGIO, que l'anomalie ne résulte pas d'une mauvaise utilisation du progiciel par le Client (ou toute autre cause extérieure au progiciel, notamment un mauvais fonctionnement du matériel ou du système).

·Loi applicable - Compétence: le présent contrat est soumis à la loi française, et en cas de conclusion avec un utilisateur professionnel, est du ressort du tribunal de commerce du siège social de la Société ADAGIO.

ADAGIO
1, rue de la Gare - 54450 BLÂMONT - FRANCE
Tél : 03.83.42.39.73 - tm@adagio.com.fr

© Tous droits réservés - ADAGIO